Taurus Car Club of America : Ford Taurus Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
'93 GL 3.0 This began about 6 mths ago. Occasionally and seemingly randomly, my battery light blinks on. Not under the same conditions and never stays on, just briefly blinks and goes out. I checked all the connections to the altenator and battery. Everything was clean and tight. The alt was making lots of noise which I assumed was the bearing going bad (170,000+ miles) so I replaced it. Nice and quiet now but the light still blinks. I just replaced the 10 yr old battery because I didn't think it had another winter left in it and this also made no difference. The belt is recent and the tensioner seems strong. What should I look at next?? thanks.
 

·
Registered
Joined
·
2,473 Posts
Since you've not outlined under what conditions the battery light comes on, make sure the belt tensioner is indicating it's within the tension range marks & the belt & pulleys are clean, no coolant, ps or engine oil on them such that the belt might slip when load is applied. Check the B- battery to engine & body ground connections, they need to be clean, bright & tight, same for the B+ cable to the alternator & under hood power distribution box & the alternators plug in electrical connector. If all is ok & still no joy, run this puppy by your favorite autoparts store for a no cost, in vehicle electrical system check up via their portable electrical system tester. Prpoerly used it can load test all of the vehicles electrical system components & will likely be able to spot your problem.
 
1 - 2 of 2 Posts
Top