Taurus Car Club of America : Ford Taurus Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
So ill start from the very beginning i hit a deer in my 93 SHO. little body damage but put a hole in my rad i took such out and replaced whilst doing so i took off the positive battery cable (as i do everytime i take connectors out) now when i was finished hooked everything back up and continued on my way my radio was i say this loosely shorting out it would flash and go to cd and tape but the music was uninterupted but was annoying enough i dexided since i have one ill put my aftermarket sterio in so i got an adapter got everything hooked up and ready took of my battery removed strerio to find the connecters didnt fit so i put the old one back in and now my clock and radio wont turn on my power locks wont lock and when i push unlock it lights up the dash but doors stay locked any ideas what i did wrong?
 

·
Premium Member
Joined
·
77 Posts
Might as well start easy and check your fuses. I've popped fuses before by accidentally grounding the hot and/or constant for the radio before.
 

·
Registered
Joined
·
18 Posts
Sounds like you got a short in the line....I would pull the radio back out and check to see that you didnt strip any wires while doing anything....Taurus's have way to many wires running in the most random places for different things so I would check that after fuses....
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #5 ·
All fuses and relays are good and as i can see wiring is too how hard would it be to rewire an aftefmarket stereo into the car bypassing factory setup but still keeping my keyless entry and clock?
 
1 - 5 of 5 Posts
Top