Taurus Car Club of America : Ford Taurus Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
424 Posts
Discussion Starter #1
The battery light on my mother inlaws 95 GL with a 3.8 has been randomly going on and off this started about a month ago. I had the battery and alternator checked out at my local autozone, they said the battery was a little low and the alternator was ok, since it was the original battery I figured that it was past due for a new one. I put in a new battery and the battery light didn't come on anymore until about a month later it came on again a few times that day, but it hasn't come on for the past several days. I have checked the battery termanals, all the wires on the alternator, and the belt, all seem to be okay.
Also when the battery light started coming on again I had Autozone check the new battery and the alternator again and both checked out ok
 

·
Premium Member
Joined
·
14,126 Posts
How many miles on it? Could be worn brushes. What is the voltage as you drive? Does it fluctuate?
 

·
Registered
Joined
·
424 Posts
Discussion Starter #3
It has 151,000 miles on it, it doesn't have a gauge only stupid idiot light so I can't tell if the voltage fluctuates as I drive. Also it looks like the original alternator but I don't know for sure since the car was bought used this past August. Other than this problem the care runs and drives great.
 

·
Premium Member
Joined
·
14,126 Posts
At a 151k I am sure the alternator brushes are down to the nubbins. This would not allow good contact and may be what is giving you the fluctuating light.
 
1 - 4 of 4 Posts
Top