Taurus Car Club of America : Ford Taurus Forum banner

1 - 11 of 11 Posts

·
Premium Member
Joined
·
3,601 Posts
Discussion Starter #1
No idea why, but my airhorn that I added only works sometimes. Just randomly.

I wired it up to a bosch relay exactly how the instructions said... idk what I did wrong.

One of my friends said it might be the horn button relay, but my stock horn works fine...?
 

·
Premium Member
Joined
·
3,601 Posts
Discussion Starter #2
Sitting at breakfast now. When I locked my car, I couldn't get my horn to honk... :( so I am thinking I'll try honking the horn going down the road later and I'll bet it won't work :(
 

·
Premium Member
Joined
·
3,601 Posts
Discussion Starter #3
Well, now I have no horn at all whatsoever.
 

·
Premium Member
Joined
·
3,601 Posts
Discussion Starter #4
Checked the Horn Relay and the Horn Fuse under the hood, and both are working fine..... :dunno: HELP!!!!
 

·
Premium Member
Joined
·
3,601 Posts
Discussion Starter #5
Took the bumper shield off... one of the horns was just sitting in there, not connected to anything... no idea how it happened but everything is fixed now. :lol:
 

·
Premium Member
Joined
·
17,415 Posts
One of those :pat: moments huh?
 

·
Premium Member
Joined
·
3,601 Posts
Discussion Starter #7
Yes. Definitely a palmface moment. like a giant massive palm.

I feel like I should apologize to anyone who read this waste of a thread. :(
 

·
Premium Member
Joined
·
3,601 Posts
Discussion Starter #9
ha. ha. no.
 

·
Premium Member
Joined
·
268 Posts
must have been one of those annoyed neighbors that unhooked it lol
 

·
Premium Member
Joined
·
3,601 Posts
Discussion Starter #11
haha, I doubt it... those horns are really hidden in the depths of the front bumper cover on G3s.... take the cover off and it's right in your face, but trying to get at it from behind is almost impossible.
 
1 - 11 of 11 Posts
Top