Taurus Car Club of America : Ford Taurus Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
My a/c isn't keeping up. It's been this way since I bought it back in the fall but now the southern summer heat has arrived. I'm pretty sure it's low on freon...I went to "the Walmart" and bought one of those large can rehcarging cans with the gauge set attached. It doesn't work with my car's fitting. Does a 2003 run r134 or what?

Thanks,
 

·
Registered
Joined
·
10,559 Posts
r134

My a/c isn't keeping up. It's been this way since I bought it back in the fall but now the southern summer heat has arrived. I'm pretty sure it's low on freon...I went to "the Walmart" and bought one of those large can rehcarging cans with the gauge set attached. It doesn't work with my car's fitting. Does a 2003 run r134 or what?

Thanks,
Everything in at least the last 10years uses that.

Check to be sure you are using the correct port on the system. The high and low are different to protect you from the big bang.

-chart-
 

·
Registered
Joined
·
10,559 Posts
Water Drain

Everything in at least the last 10years uses that.

Check to be sure you are using the correct port on the system. The high and low are different to protect you from the big bang.

-chart-
One more:
If it cools any at all, meaning the compressor is turning, and one side it warm and the other is cold in the tubing, then you should have water draining from the condensate drain on the firewall. This happened on my '01. I took the R front tire off and inner fender. Ran a lenght of quarter inch plastic tubing up and around the bend, and water ran out. Has been working fine ever since.

-chart-
 

·
Super Moderator
Joined
·
8,586 Posts
^^^^^ +1

You are trying to attach it to the high side port. You MUST charge thru the low side port unless you want the can to explode in your face.

To properly charge the system, you need to look at BOTH the high side and low side pressures!!!! The pressure gauge that came with the kit is virtually worthless.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #5 ·
Yes, it gets a little cool but won't keep up with this 90° weather. I could only find one port. It's on the left hand side of the engine compartment on top...I never could find another one.
 

·
Registered
Joined
·
159 Posts
the low side port is located right beside the passenger side strut tower, close to the firewall. you might have to unclip some vacuum lines and the washer fluid line to get at it.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #7 ·
I found it. facing the car it's on the lhs on the firewall under the cowl mixed in with the other lines...LOL!! It took the whole bog can and feels pretty good already...thanks guys!
 
1 - 7 of 7 Posts
Top