Taurus Car Club of America : Ford Taurus Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
185 Posts
Discussion Starter · #1 ·
After getting the UIM/LIM replaced on my '01, the mechanic also told me that the ABS module is bad. The warning light for the brake had come on recently, and after checking the obvious (fluid level, e-brake, etc), he determined that the ABS module was no longer functioning.

I see that Rock Auto lists one on their site for $310, which I'm sure is several hundred cheaper than the dealership. Does anyone have any other aftermarket sources for this? AutoZone and O'Reilly's weren't showing any listings. Has anyone tried buying one from a junkyard? I'm reluctant to go that route, since you really have no idea when these things are going to go bad.
 

·
Registered
Joined
·
23,579 Posts
Is the red brk. lt. or the amber abs lt. on? Or both? Did he scan the abs system with an abs scanner, check the wheel sensors and tone rings? If its just the red brk. lt. thats on, and fluid is full and e-brk. is fully released, it could be the switch in the bottom of the master cylinder reservoir. Unplug it and spray with elec. clnr. or replace reservoir. Maybe spray the switch above the e-brk. pedal on its arm with wd-40.
 

·
Registered
Joined
·
185 Posts
Discussion Starter · #4 ·
Is the red brk. lt. or the amber abs lt. on? Or both? Did he scan the abs system with an abs scanner, check the wheel sensors and tone rings? If its just the red brk. lt. thats on, and fluid is full and e-brk. is fully released, it could be the switch in the bottom of the master cylinder reservoir. Unplug it and spray with elec. clnr. or replace reservoir. Maybe spray the switch above the e-brk. pedal on its arm with wd-40.

Actually, it's the red brake light (on the far right side of the dash) that's on. I've sprayed the switch the above the e-brake with wd-40 before, and it didn't have any effect on the light. Is it possible that the e-brake does not release fully even when I release it? I don't use the e-brake, and I don't think my son does either.

I'll have to try the switch in the bottom of the master cylinder reservoir -- that's the first I've heard of that.
 

·
Super Moderator
Joined
·
8,732 Posts
To eliminate the E brake switch, pull the connector off the switch.

I am unaware of any ABS problem (module, speed sensors, etc) that will only turn on the red BRAKE light and not the yellow ABS light. I am to lazy to dig out my EVTM and look, but I dont think there is any connection at all between the BRAKE light and the ABS module.

Test the ABS system and see if it works. Get moving and stomp the pedal and see if the ABS kicks in. If it does, the entire ABS system is operational.
 

·
Registered
Joined
·
185 Posts
Discussion Starter · #6 ·
I tested the ABS system just a bit ago, and it does work. So I think we can rule the ABS out.

Where is the connector to the e-brake switch? Is it right above the base of the pedal?
 

·
Registered
Joined
·
1,365 Posts
Usually the parking brake switch fails by corrosion not letting it close (light doesn't illuminate). Most likley it's the level sensor in the master cylinder, as mentioned. I wouldn't let your guy do any more diagnostic work, BTW, if he can't even separate the two warning lamps and do a basic ABS test. :unsure:

I'm so judgemental...
 

·
Devoted Member
Joined
·
2,426 Posts
Usually the parking brake switch fails by corrosion not letting it close (light doesn't illuminate). Most likley it's the level sensor in the master cylinder, as mentioned. I wouldn't let your guy do any more diagnostic work, BTW, if he can't even separate the two warning lamps and do a basic ABS test. :unsure:
Yeah, I'd kick that "mechanic" to the curb...

I'm so judgemental...
Old people are like that...
 

·
Registered
Joined
·
185 Posts
Discussion Starter · #9 ·
Haha.....believe me, I am going to send the mechanic packing. The only good news I got was the U/L intake manifold gaskets were installed for $200, so I was happy about that.

Is that level sensor actually on the passenger side of the reservoir, almost at the bottom?
 
1 - 12 of 12 Posts
Top