Taurus Car Club of America : Ford Taurus Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
I have made a few posts on the account I actually created about a month ago with the username TheGreenBstrd. When I went to log in the other day it would not accept my password. I entered my email to reset the password and I was told the email could not be found. So I emailed the moderators and now I have been given someone else's account which is now mysteriously linked to my email. When I go to the posts I have actually created my former username is not even clickable like it has been deleted. This is very frustrating and as a new member to the board is is discouraging.
 

·
Administrator
Joined
·
14,337 Posts
I've passed this along to the helpdesk to see what they can find. The only username associated with your IP address is this "Ryan" account. User accounts are never deleted, however I can't find any information on "TheGreenBstrd". I'll let you know what they have to say about that account.
 

·
Administrator
Joined
·
666 Posts
Hey there,

On your TheGreenBstrd account, do you remember any thread titles that you created or posted in?
Did you inquire about changing your password or email address at any point with us?

Richard.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #7
Yes that was my first post after my introduction http://www.taurusclub.com/forum/104-introduction-forum/321473-hello-michigan.html.
I never asked for a reset on anything before I had the problem logging in. I went to log in the other day to update the post with the wheels and tires I purchased for winter and I could not log in. At that point I emailed [email protected] and they could not find my username. When I provided my email and IP address I was given this account. Maybe because my name is Ryan but this is not my account and if this person was a current and regular forum member they would probably be upset that their username got handed to someone else.
 
1 - 8 of 8 Posts
Top