Taurus Car Club of America : Ford Taurus Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
let me start by saying hi, im new to the forums.. i have a 97 taurus 3.0 EFI,with manual AC controls, the other day ac just stopped working, was working great and freezing me out..then i get in it and the controls were left on and nothing.. so i checked all my fuses, ran current threw them they check out, checked my compressor and it is kicking on when AC control turned on.. so i did some research and found these cars have problems with blower motor resistor, so i went on down to auto store picked on up changed it still nothing.. i pulled my control panel out and checked by running current threw those, everything is fine.. so i finally pulled my blower motor seeings i cant even hear it kick on i hook it up to a battery and it starts spinning.. so now i am out of ideas on all the DIY stuff.. so i am really hoping for some more opinions and suggestions.. i have to drive out of state sunday and its going to be hot im hoping to maybe get something determined by then.. thanks for your help,its very much appreciated!
 

·
Registered
Joined
·
56 Posts
Generic suggestion...

So, after all work you already done, you know 3 things:
1. Your battery is good.
2. Your blower motor is good.
3. It doesn't spin when it should, what means that circuit between battery and motor is open when it should be closed.

Now you have to take electrical schema of that circuit and check everything in it starting from one end or another - I don't think it will be that complex.

Good luck.
 
1 - 2 of 2 Posts
Top