Taurus Car Club of America : Ford Taurus Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
364 Posts
Discussion Starter #1
AC season is here or nearly depending upon your location. Experienced intermittent compressor clutch engaging, sometimes, then not, would sometimes cool for five to seven minutes, then warming up. It might come back on cooling then randomly quit.

I managed to check with manifold gauges when operating and refrigerant levels were fine, not low. Checked the low pressure switch by jumping and still no engagement. Checked the temperature control (manual controls) as well as the actuator, both fine. Checked the mode selector and vacuum lines, all seemed fine. Next checked under dash fuses as well as power distribution box under hood. I am starting to wonder if the clutch air gap is too wide. I pulled the AC clutch relay in the power distribution box and the receptacle terminals were rusty, had white and green corrosion. I cleaned up the terminals as best possible and switched a known good relay and the compressor engaged each time, every time. Plugged in suspected bad relay in another spot and it was dead. So in my case it was a bad relay (position 33) on mine.

Now a question. I had this same problem a year or two into ownership and it was fixed by the dealer under warranty. Apparently the box does not keep moisture out or pools to this area, other relays all dry and corrosion free. What can I do to prevent this corrosion??? I think corrosion starts then backs up into relay causing its failure? Anyone else have this problem? Would dielectric grease help? Appreciate suggestions.

Scott
 

·
Registered
Joined
·
9,912 Posts
My solution of choice. It is available at many hardware stores and most big box home stores

+1 on that, mine came in a tube, from Lowes. Small tube will last a life time. I pulled all my outside relays and used Q-tips and put a small amount on all the tabs. Also used on my ground to fender connections. Sanded the paint off, used a dab of that stuff so no rust will creep in.

-chart-
 

·
Registered
Joined
·
507 Posts
Dielectric grease will do just fine. And, if you can find something similar and it costs less go for it. Dielectric is used because it can be cleaned and/or wiped off easily when and if necessary, yet stays where you put it and allows the relays/fuses to be easily removed when necessary. The under hood fuse/relay box is open on the bottom, probably so that water will not puddle there and cause oxidation (rust?) on the female contact plugins.
 
1 - 5 of 5 Posts
Top