Taurus Car Club of America : Ford Taurus Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
222 Posts
Discussion Starter #1
water pump

Installed by pass kit replaced water pump, and replaced tstat with a 180F. The above pic may answer anyones question on if they should replace there water pump
 

·
Registered
Joined
·
21 Posts
At least you still had some fins left on your impellor....All that was left on mine was the hub!! '97 vulcan w/89k miles.

-reever
 

·
Registered
Joined
·
21 Posts
Hey Green, Do you have info on the bypass. I have the TSB somewher around here, but was wondering if you had any more info. Did you get the parts from the dealer or did you scrounge them up on your own? After changing the water pump and flushing my heater core all by itself, it might be advantageous to do the bypass.

Thanks
-reever
 

·
Registered
Joined
·
222 Posts
Discussion Starter #4
Originally posted by reever@Apr 28 2004, 08:38 AM
Hey Green, Do you have info on the bypass. I have the TSB somewher around here, but was wondering if you had any more info. Did you get the parts from the dealer or did you scrounge them up on your own? After changing the water pump and flushing my heater core all by itself, it might be advantageous to do the bypass.

Thanks
-reever
Part#F7DZ-8522-AB Lists price $30.00 for the by pass kit.
 

·
Registered
Joined
·
379 Posts
Interesting pic. I was wondering what a brown coolant water pump looked like.
 

·
Registered
Joined
·
62 Posts

is a worn water pump causes coolant to turn brown?
coz i have replave my heater core 2x already and now i'm observing it and it seems that coolant is turning brown again. i have 97 gl taurus 68K in it.
 

·
Registered
Joined
·
21 Posts
Thanks green, but I found the TSB with the correct part #'s. It was buried in my files here at work....

Rockledge, you one and the same from FTE? Maybe you can post up the link for the folks here about the bypass. Has some good info about the problem. Of course, if you aren't the person I am thinking of, then my apologies sir!

-reever
 

·
Registered
Joined
·
379 Posts
Originally posted by reever@Apr 29 2004, 09:39 AM
Rockledge, you one and the same from FTE? Maybe you can post up the link for the folks here about the bypass. Has some good info about the problem. Of course, if you aren't the person I am thinking of, then my apologies sir!

-reever
Yep, same 'ol Rockledge from FTE.


Actually, I already posted a link to the TSB in a previous "brown coolant" thread here at TCCA:

http://www.taurusclub.com/forum/index.php?showtopic=764

 

·
Registered
Joined
·
379 Posts
Originally posted by FRAG24@Apr 29 2004, 01:18 AM

is a worn water pump causes coolant to turn brown?
coz i have replave my heater core 2x already and now i'm observing it and it seems that coolant is turning brown again. i have 97 gl taurus 68K in it.
The water pump degrades as a result of the brown coolant problem, not vice versa.
 
1 - 9 of 9 Posts
Top