Taurus Car Club of America : Ford Taurus Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
About a month or so ago, I started having a problem that when I would turn on heater, roll down window, etc, my car would jerk, and the rpms would go down, some of my dash lights would come on, but then it would go right back to normal. Took it to the dealer, and had them put it on the machine, they said they were 75% sure that it was the belt and/or the belt tensioner. Boyfriend replaced both and didn't seem to have the problem any more. Just yesterday, I started having pretty much the same problem, almost every time I would put on the brakes, roll down my windows, use turn signals, turn on heater, etc. it would do the same thing. My brother asked around and everyone said the same thing, that it sounds like my computer. How can I find out for sure and how much could that cost me? Any advice would be appreciated.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Sorry, forgot to mention that, I did take to Autozone yesterday, and had the alternator tested, they said it was fine, they showed me that it was running at 14 like it should be.
 

·
Registered
Joined
·
346 Posts
I replaced the computer in my 97 after it was acting screwy. I took it to my friends shop and they hooked it up to there computer tester thingy. They couldn't get it to throw a code and store it. I got a junkyard computer for like 45 bucks, easy install. Now all I need is a new MAF sensor, to replace the one my brand new K&N screwed up. K&N is teh loose.
 
1 - 4 of 4 Posts
Top