Taurus Car Club of America : Ford Taurus Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter #1
Does anyone know the proper configuration or picture of the heater hose coming off the water pump to heater core? Is it a direct connection to the heater core or does the line have a T- connection takeoff going to the thermostat side of the engine. Mine has an after market hose going directly to the heater core at the fire wall.
 

·
Registered
Joined
·
18 Posts
QUOTE (fisher @ Mar 20 2009, 05:15 PM) index.php?act=findpost&pid=710735
Does anyone know the proper configuration or picture of the heater hose coming off the water pump to heater core? Is it a direct connection to the heater core or does the line have a T- connection takeoff going to the thermostat side of the engine. Mine has an after market hose going directly to the heater core at the fire wall.[/b]
Yes, I just checked mine and the heater hose runs from the water pump to a metal pipe that goes around and to another hose that goes directly into the heater.
 

·
Registered
Joined
·
41 Posts
Discussion Starter #3
QUOTE (jerrysanta @ Mar 22 2009, 08:40 PM) index.php?act=findpost&pid=711285
QUOTE (fisher @ Mar 20 2009, 05:15 PM) index.php?act=findpost&pid=710735
Does anyone know the proper configuration or picture of the heater hose coming off the water pump to heater core? Is it a direct connection to the heater core or does the line have a T- connection takeoff going to the thermostat side of the engine. Mine has an after market hose going directly to the heater core at the fire wall.[/b]
Yes, I just checked mine and the heater hose runs from the water pump to a metal pipe that goes around and to another hose that goes directly into the heater.
[/b][/quote]

I think you have a different engine, replaced hose per TSB....all is working fine now...
 
1 - 3 of 3 Posts
Top