Taurus Car Club of America : Ford Taurus Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Question here I think I know the answer to.

This morning when I pulled my 95 Taurus into work I pulled up too far onto the railroad tie separating parking lots, it snowed a lot and couldn't see it. I backed it off and then went into work. When I left for lunch and came back I noticed a nice red trail where I had backed out to go to lunch. Being as I'm in my office clothes I couldn't get under to check.

I suppose I dinged up my power steering pump. It was making noise and I could tell needed fluid added before this morning, so I didn't notice any difference there.
 

·
Cake monster
Joined
·
1,584 Posts
Question here I think I know the answer to.

This morning when I pulled my 95 Taurus into work I pulled up too far onto the railroad tie separating parking lots, it snowed a lot and couldn't see it. I backed it off and then went into work. When I left for lunch and came back I noticed a nice red trail where I had backed out to go to lunch. Being as I'm in my office clothes I couldn't get under to check.

I suppose I dinged up my power steering pump. It was making noise and I could tell needed fluid added before this morning, so I didn't notice any difference there.
You're sure it isn't tranny fluid? How many P/S pipes are there in the front of the car? I don't have one that old.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 · (Edited)
Is the Transmission Lines in the front?

I don't know where anything is under it. I just bought it a couple months ago as a beater / commuter car for my 100 mile commute every day.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
Probably snagged ps cooler hose/line under the front of the car.
Thanks... That's what I was hoping to hear. I'll pull it in the garage tonight and lift it up to see what's up. Luckily there is a parts store a block from where I work.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #9 ·
Calm down.... I only had to go a mile.

Whoever had the car before just put a rubber hose and hose clamps on there. One popped off. Tranny fluid is topped off and good to go.
 

·
Registered
Joined
·
23,349 Posts
Yeah, youve got tranny and ps cooler lines/hoses running in the front down there. Funny, just 2 days ago i had to snug a hose clamp on the small tranny line i noticed was seeping while doing an oil change.
 
1 - 10 of 10 Posts
Top