Taurus Car Club of America : Ford Taurus Forum banner

1 - 5 of 5 Posts

·
Premium Member
Joined
·
2,170 Posts
Discussion Starter #1
My water pump has started leaking, I've got one in my garage which a bought last year when I was replacing the headgaskets, but I never bothered to put it on. What kind of a job am I looking at? Does anyone have any tips? I plan on replacing the thermostat and flushing the cooling system out while I'm at it too.

Thanks!
 

·
Registered
Joined
·
256 Posts
shouldnt be too hard...although ya prolly shoulda done it while ya were doin your gaskets...thats when i changed mine out...also...check the radiator tube assembly that goes from the radiator to the pump...when i chnaged out my pump i discovered it was BADLY corroded(thats what caused my head gaskets to go)...its a dealer only item and its kinda hard to find...expect to pay about 80 bucks if ya do need it...good luck!
 

·
Premium Member
Joined
·
2,170 Posts
Discussion Starter #3
oh yeah, that damn tube looked confusing. How is it held in the pump? How do I get it off the pump? Thanks a lot!
 

·
Registered
Joined
·
256 Posts
Its held in place by a rubber o ring, it shoudl come off with just a hard tug or two, but you wouldnt really need to remove it if it needs replacin, just take the tube and water pump out as one piece...thats it i think...how many miles does your Sable have?...mine only had 66k on it when we did the gasket job...if yours has more that tube is prolly fried, Like i said...about 80bucks for the part and i think the o-ring is separate and its only 2.75...but It'll keep your car alot cooler. I forget how it came out seein as I wasn't too invlolved on the process of the gasket job. A friend did it and said he'd charge me extra if I bugged him by watchin over his shoulder....lol :D But he hooked me up,,,i supplied most of the parts like, new power steering lines(a WHOLE LOT EASIER to change out when the engine is torn down), new water pump, that tube, gasket kit and motor mounts and he installed them all and only charged me 150, was 250 but he took 100 off cause my hood got damaged slightly while he was workin on my car...someone ran over it or somthin..not too bad...but anyways..im rambling...good luck with the pump
 

·
Premium Member
Joined
·
2,170 Posts
Discussion Starter #5
Thanks for the reply. I dug into the job today and got the pump out. The tube confused me because it looked like it was glued into place, but it is indeed held on with only the o ring, but sombody JB welded it in place at one point to stop a leak :lol2: Getting that pump off was a pain in the ass, a few studs came out with the nuts, so I had to get the nuts off before the pump would slide out, and I also had a top 10mm bolt snap on me, damn. It left a big piece to hold onto so hopefully some vice grips will solve that problem.

The tube that goes to the lower radiator hose is fine, a tiny bit of rust in it, but I'll clean it off and paint it so it dosen't rust anymore, but I've got to go to work now so I'll continie the repairs tomorrow. I think I can make it to work with no water pump, it's only 3 miles away.. haha, J/k I'm taking my moms motorcycle.
 
1 - 5 of 5 Posts
Top