Taurus Car Club of America : Ford Taurus Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Ok I have a few issues with my 92 Taurus. I got this car for $1800 and it only has 67,000 miles. It was an old undercover cop car and I have had to do some minor eletrical repairs to the radio and dash lights. But I haven't spent any more time yet!. I have done normal maintance but I have a few things need to do..
Problems
1. After stoping (at a light) when I go to take off. I take my foot off the brake but the passenger front wheel seems to hesitate. It almost pops in. ???? :(

2. My read defrost and power mirrors have never worked. The lights behind them and the headlight switch don't work either? Relay issue???? :angry:

3. And over all it just seems to run a little rough "RUFF". Not to bad but at times its noticable. I may be time for a tune up. I noticed all the sensor things. From other forums.

Thanks in advance for your feed back. I will keep you updated.

I love this car.
She might not look like much but she's got it where it counts.
 

·
Premium Member
Joined
·
6,077 Posts
Welcome to the :tcca:, first off! If you love your car, yo'll really love this site. Look around!

1. Pops in? Pops into gear or the wheel pops into the fender? :???: Gonna have to gimme some more info here.

2. Does the rest of the dashboard light up? How about the dome light? Is your dimmer rotary switch on? I can't remember what fuses controlled what, but there's a good place to start.

3. Cap, rotor, plugs and wires might make a difference. A stutter may be from a clogged fuel line or a bad filter. Make sure your airbox is clean of debris. Is it throwing any Check Engine Lights (CEL)?
 

·
Premium Member
Joined
·
15,578 Posts
Welcome to the club. Definitely check and replace any bad fuses, and since it is a 92', replace all the electrical parts that TrueBlue said, and possibly also look into new injectors, or run a can of Techron fuel system cleaner through. It's about 15 bucks, but it's worth it. You might also want to add a can of Marvel Mystery Oil into the oil the next time you change it.

JR
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Thanks guys your awesome..

OK yeah.. more info.

1. Its a real small pop. More of a hesitation than anything.. almost like the left wheel is moving and the right isn't.. my initial thought is that the brake may be catching.. its almost like that.. every heard of that?

2. Yeah everything else lights up.. just everything on the left side but the headlight switch does work.

3. Yeah I need to give it a tune up.. and change the fuel filter.. that will probably happen tomorrow after work. :chili:
 

·
Premium Member
Joined
·
15,922 Posts
I would guess the light's burned out. The light for the headlight switch is constantly on when the ignition is in ACC or ON positions. It's not a big deal since you know where the switch is and it clicks into position. You'd have to take the dash apart to get it so you probably want to wait until you want to put in a new cluster (for a tach) or something before you change the lights.
 
1 - 5 of 5 Posts
Top