Taurus Car Club of America : Ford Taurus Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
hello,
im new to this forum, i came here in search of a answer to why my 89 Taurus keeps dieing.

what happens :
i can start the car right up, drive it around the block and as soon as the cooling fan starts up the car dies. after it die i can wait 10-20 minuets then it will turn over have no problems till the cooling fan kicks on.

when this started happening:
one day started the car up went to the gas station, filled up the tank went to start the car......... nothing.... towed it home.

what i have done:
replaced water pump, battery, fuel pump and filter, spark plugs, got alternator tested (passed) and all fluids.

i love my green bean so much and would hate to part it out D: if anyone could please help me to save it i would appreciate it so much.

thank you for your time
cory
 

·
Registered
Joined
·
194 Posts
It could be the IAT (intake air temperature sensor) is done and sending a false high reading. What engine by the way?
Wrong section too, probably get more replys in maintenance or engine.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
It could be the IAT (intake air temperature sensor) is done and sending a false high reading. What engine by the way?
Wrong section too, probably get more replys in maintenance or engine.
thank you so much for responding, i took the sensor out cleaned it off and the car is running like new.

i was thinking this problem would electrical so that is why i posted it here.

thank you so much for your help :D
 

·
Registered
Joined
·
194 Posts
Hey no problem. I had the same issue with my old 89 but i didn't find out it was somthing that simple until i traded it in.
 
1 - 4 of 4 Posts
Top