Taurus Car Club of America : Ford Taurus Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Any one have any idea what are some sign this part needs to be replaced .I did change the ERG valve and the ERG Solenoid but still I am getting a stumble or slight miss in the wifes 2004 Sable.
my next question on the Sable the part seem to be in the rear of the engine mounted to the intake block manifold ,I see 2 small vacuum lines and a elect connector any idea how to remove and change this part.I can only feel that the part is mounted with 2 small screw 8 MM socket other then that really hard to see the part
 

·
Super Moderator
Joined
·
7,836 Posts
Why did you replace the EGR valve and EGR solenoid? Why do you want to replace the DPFE? 99% of the time a failing / failed DPFE will set a specific code or set of codes. Ford EGR valves virtually never go bad and solenoids rarely go bad. Throwing parts at the car with no idea what is really wrong will get expensive very fast and probably not solve the problem.

Your problem likely has nothing to do with the EGR system. More than likely you have a vac leak, partly plugged injector, fuel pressure problem, failing coil pack, bad plug wire, bad spark plug, etc. First thing you need to do is use a scan tool to look for hard codes and pending codes and look at long term fuel trims on both banks at idle and at 50 mph cruise.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #3 (Edited)
We Did use a Scan tool to look for hard codes and pending codes
car comes up with no codes and no check engine light.The sable runs excellent other then a stumble here and there she may not do this for a week or so run excellent then maybe and day or two a stumble here and there then it disappears.
I also change the plugs and the gas filter other then that the mechanic states wait until it start throwing a engine code or check engine light to come on.
 

·
Registered
Joined
·
1,192 Posts
Take apart throttle body and see if the passages to egr is blocked. Run a wire through them and clean really good. If they are clogged, nothing works right. Cheap start and often the real problem. I was throwing a Po401 in my F-250. Was bad ports to the sensors, totally clogged. Took and hour or so, Gas mileage up 3 mpg~~
 
1 - 6 of 6 Posts
Top