Taurus Car Club of America : Ford Taurus Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I posted this before but put it in the Intro forum - oops.

I'm getting just the P0446 - no other codes.
I've checked the gas cap and tried a second one from a different car.
I've pulled the canister and tested the vent valve on the bench. Canister looks clean and fittings were tight, hoses look good.
I can't see the fuel filler pipe connection to the tank - hope that is not it.
I've removed and tested the purge solenoid on the bench. Fittings/hoses look good.
Chased the hoses from front to the canister and they look good.
I created my own (crude) smoke machine and stuck it in the tube at the intake and plugged the intake hole (so, the car would not die). I found no leaks but I'm not sure if this was the right way to do a smoke test. I had the engine running which I think would open the purge valve and force the smoke back to the canister. Is that the right way.
I fear the problem is the ECM signal wiring and I'm not sure how to troubleshoot that.

Any help is much appreciated.

Thanks, Bill
 

·
Registered
Joined
·
4 Posts
Discussion Starter #2
I've learned a little more on this issue. The vent valve works fine on the bench. I have 12V at the vent valve connector on the canister. My mechanic can command the PCM to try to control the vent valve but it does not open/close. So, the problem is in the ground wire back to the PCM. I cannot chase it back to the PCM since it is buried in a cable harness to the PCM.

The million dollar question is does anyone know what terminal on the PCM this ground wire from the vent valve is landed?

Thanks,
Bill
 
1 - 2 of 2 Posts
About this Discussion
1 Reply
1 Participant
nevinnh
Taurus Car Club of America : Ford Taurus Forum
A forum community dedicated to the Ford Taurus and SHO models, Mercury Sable and Lincoln MKS. Join the discussions on EcoBoost, aftermarket performance, and more!
Full Forum Listing
Top