Taurus Car Club of America : Ford Taurus Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
So about a week ago I had my spark plugs and some igination coils replaced. Everything was fine until recently. Today I was heading home and I noticed that my car wasn't getting near as much power as it usually does. (not electrical) It was not accelerating properly. So I gave it a some gas and the car shot up to around 5000 rpm with little to no acceleration, it shifted properly and then I heard a little pop sound.

Then after that every time I accelerate my car makes a sound that seems to be coming from under the dash. It sounds like a small air compressor blowing air with a little bit of rattling. The shifting and everything else is fine. Just little to no power.

I really don't have much money to get it fixed and I really don't know much about engines however I just need a place to get started on figuring out what this problem is.

(btw I have no check engine light)
 

·
Premium Member
Joined
·
7,537 Posts
That sounds like you have a clogged exhaust. If you drove around with bad plugs for too long you probably melted the catalytic convertors.
 

·
Premium Member
Joined
·
7,537 Posts
If you have a pressure gauge you can hook it up to one of the DPFE lines and check the pressure at 2000 RPM. Should be less than about 1 psi.
 

·
Registered
Joined
·
540 Posts
The lake of power sure sounds like a possible clogged cat but I don't think that would generally cause the air rushing sound you are hearing near the dash. Check out the air filter box to make sure it doesn't look damaged and then open it up to check your air filter to make sure it's not clogged. If it's clogged replace it and clean out any debris in the air box.
 
1 - 7 of 7 Posts
Top