Taurus Car Club of America : Ford Taurus Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
My oldy has some issue again. The engine is hard to pass 2000RPM and engine sound loud but not squealing or Knocking.
There was also some smell of burn engine oil...Can it be bad spark plug or something else? Thanks
 

·
Registered
2000 Taurus SES 12v
Joined
·
871 Posts
Most likely you can also smell coolant coming out of the tail pipe when the engine is running. That is assuming you are using coolant and not water, because there is of course always water coming out of the tailpipe.
 

·
Super Moderator
Joined
·
8,877 Posts
Are you sure the liquid isnt just condensed water from the combustion process?

Looks to me like the muffler clamp isnt close enough to the joint in the pipes to seal properly.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #8 ·
After seal the exhaust leak, still had problem speed up, especially after stop. Engine sound was not smooth (
). Ignition system test was fine. After 10 min drive, noticed white smoke under intake manifold... Coolant level seems stable (haven't add for months).. Can it be dead gasket leak?


Motor vehicle Electrical wiring Automotive exterior Automotive tire Auto part
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #12 · (Edited)
Just get time to deal this Taurus again.
Use a vacuum pressure gauges to access one DPFE port. Following reading is when the engine RPM is 2000. Looks like plug exhaust?

I also measured the temperature before and after catalytic converters. The rear catalytic converter: 267F before catalytic and 130F behind.


The rear catalytic converter seems not working. I remember I saw dripping water months back, what can be the cause, should I use Lacquer thinner to clean (put in gas tank) if these is no exhaust leak


Light Gauge Motor vehicle Speedometer Measuring instrument
 
1 - 13 of 13 Posts
Top