Taurus Car Club of America : Ford Taurus Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 · (Edited)
I have a 2003 Taurus that has an erratic idle in gear which gets worse as the car warms up. The check engine light has not come on. I have replaced the iac and has not solved the problem. I have searched the forum and can't get a good idea of what to try next. Maybe the coolant temp sensor or maf? Any suggestions would be appreciated.
 

·
Registered
Joined
·
1,047 Posts
The MAF would throw a code if it were malfunctioning and does not have any effect on idle speed. However a vac. leak could cause this issue, check your PCV "L" hose and the PCV grommet going into the left valve cover, they wear out and cause irratic idle.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thank you. I checked the PCV L hose this morning. It looks practically new and has been recently replaced. Doesn't seem to be the culprit. Plus wouldn't a vacuum leak cause the car to idle rough and surge all the time not just when warmed up?
 

·
Super Moderator
Joined
·
8,591 Posts
You have a vacuum leak. Verify by using a scan tool to look for high positive long term fuel trims.
 

·
Registered
Joined
·
1,047 Posts
Jeff is right, you have to remember metal expands and contracts with temperature, if it's an intake manifold leak (Plastic in your case) on an Iron block they expand and contract at different rates and if you have a gasket going bad it can present itself this way. Thank you for checking the PCV, it is VERY common for the hose to rot and leak or the grommet to become loose in the valve cover.
 
1 - 5 of 5 Posts
Top