Taurus Car Club of America : Ford Taurus Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I have a 2003 SES with 90k miles. It had a transmission rebuild about 3 months ago and has been running fine until this week it has started stalling when I am coming to a stop. It has happen when braking from high and low speeds. When the car slows down the RPMs drop to below 500 most of the time it "bounces" right back up but every few stop lights it stalls when the RPMs get low. Also it seems to happen more often if I am turning while braking. Once I put the car in park it starts back up no problem.
 

·
Registered
Joined
·
10,675 Posts
I have a 2003 SES with 90k miles. It had a transmission rebuild about 3 months ago and has been running fine until this week it has started stalling when I am coming to a stop. It has happen when braking from high and low speeds. When the car slows down the RPMs drop to below 500 most of the time it "bounces" right back up but every few stop lights it stalls when the RPMs get low. Also it seems to happen more often if I am turning while braking. Once I put the car in park it starts back up no problem.
Likely IAC (idle air control) sticking. It adjusts for coasting, for PS pressure, and for trans N or in D as well as for A/C. Sounds like it sticks near closed and fails to open to control idle speed. On restart, it goes full open signal for starting.

I cleaned my two with Naptha and q-tips.

Quick test. Idle warm engine in N. Put it in D and note the rpm change. Usually there is a slight up and quickly back to the same rpm as in N. Same for A/C on or off.

I was happy with about 50 rpm max to min load. (about as there are only 100 marks on my tac.

-chart-
 

·
Registered
Joined
·
23,405 Posts
You can also remove and clean the iac with throttle body/air intake spray cleaner or brake cleaner. Was torque converter replaced with tranny rebuild?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #4 ·
@Sheilla I do not know if the torque converter was replaced I assume that it was. It was a $2600 bill. I checked the voltage to the IAC and it is within the range 11.98 DCv to be exact. @Chart when I warmed it up and changed it from N to D the RPMs dropped about 50 and came back up, same with the A/C. I do not have an O-ring on hand to replace the one on the IAC if I take it off so I will try that tomorrow after I can get to the parts store and pick one up.
 
1 - 6 of 6 Posts
Top