Taurus Car Club of America : Ford Taurus Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
2003 ford taurus SES/V6/82,000/4 new tires/balance well

Check engine is always on because of the oil gauge does not work, which always shows zero and can not give the correct info.

Two weeks ago, I changed engine oil, after that, I found my car began shaking when accelerate to around 40-50 MPH, especially when the AC is on, it would be more serious. Yesterday, when I was driving in the freeway upgrade, I found it was hard to speed up, shaking and checking engine light began flashing, after 1-2 minutes, the light stopped flashing.
I felt like maybe one or two of engine works discontinuously, is it because of the electricity circuilt problem, need I to change the circuit?

Thank you so much for your help. :):)
 

·
Super Moderator
Joined
·
8,586 Posts
Flashing CEL = serious missfire that will damage the cats in short order. Have codes scanned to find the cyl or cyls that are missfiring ASAP. I suggest not driving the car or driving short distances only with light throttle until the problem is diagnosed correctly and fixed.

First guess would be bad plug(s), wires, or coil pack. Has the car ever had any of these replaced?
 

·
Premium Member
Joined
·
7,307 Posts
Was engine cleaned recently or oil spilled on it accidentally??
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Flashing CEL = serious missfire that will damage the cats in short order. Have codes scanned to find the cyl or cyls that are missfiring ASAP. I suggest not driving the car or driving short distances only with light throttle until the problem is diagnosed correctly and fixed.

First guess would be bad plug(s), wires, or coil pack. Has the car ever had any of these replaced?
thank you very much for your suggestion. I will send my car to the dealer to have a test. I have never changed the plugs.
 
1 - 5 of 5 Posts
Top