Taurus Car Club of America : Ford Taurus Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
2002 Mercury Sable wagon - 24v DOHV Duratech

This is an odd one. Speedometer works fine expect when you turn on the brights, either by pulling lever- like flashing your brights or moving it forward to leave them on.
The speedometer dives to zero, then soon as you let up on the brights speedometer returns to current speed.

Any ideas?

Thanks,
Ed
 

·
Registered
Joined
·
9,649 Posts
See pic. Note: S211 connection, that goes from the high beam to the cluster for the High Beam light. A crossed connection in the cluster or the wire to the cluster can cause the signal to kill some other things in the cluster. Note: the HL are tuned "on" by grounding the bulb so the S211 is grounded when high beam is on and thus turns on the high beam light.

-chart-
 

Attachments

·
Registered
Joined
·
4 Posts
2002 Mercury Sable wagon - 24v DOHV Duratech

This is an odd one. Speedometer works fine expect when you turn on the brights, either by pulling lever- like flashing your brights or moving it forward to leave them on. Visit Autofthings to review best multimeter for automotive if you concern.
The speedometer dives to zero, then soon as you let up on the brights speedometer returns to current speed.

Any ideas?

Thanks,
Ed
It could be bad wiring or faulty fuse. When the fuse of speedometer is not working, it can cause the speedometer to drop down to zero.
 
1 - 3 of 3 Posts
Top