Taurus Car Club of America : Ford Taurus Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
This is a standard 2001 Taurus, not a DOHC.

It all started with the car not starting back up after short drives to the store and having to be jumped. I decided to have the battery replaced since the posts seemed to be getting corroded shortly after cleaning them. New battery from auto zone did not solve the problem.

I decided to have the alternator tested at auto zone and they said it was bad. New alternator from auto zone did not solve the problem.

Since then I have changed the fuel filter and swapped fuse 16 (fuel pump relay) with fuse 17 (rear control unit, cd changer, cellphone).

The reason I tried swapping fuses was because at one point while driving the ABS light came on and the tachometer dropped to zero at a stop light. When the light turned green the car had trouble accelerating for a sec then jumped forward and everything went back to normal. When i turned the car off after getting home I could not get the engine to turn over and couldn't hear the fuel pump priming. Left it sit for an hour and it started right up.

Today I tried reproducing those symptoms by driving it a few miles and letting it run for a few minutes in a parking lot. After the car warmed up the ABS light came on, RPM dropped to 0, gas gauge started going up, speedometer stopped working, and had no power to the windows or locks. I had problems accelerating all the way home. Tried to start it back up at home and couldn't even get it to crank... just a rapid clicking noise. Waited an hour and it started right up.

I cannot afford to take it to a mechanic right now so I'm just trying to find the problem myself with very little car repair experience. What should I look for under the hood?
 

·
Registered
Joined
·
6 Posts
That is the exact same thing that happened to my car. Sitting at a gas station trying to figure out how to fix it. If you found a solution please call me at 2535692886.
 

·
Registered
Joined
·
6 Posts
Thanks for the advice, but I don't quite agree. I changed out the battery and everything seemed great. It even fixed a couple problems that happen while driving. It usually shifted hard into first and coasted waaaaay too fast. Those problems were cured and then a day later those problems while driving came back and now today the car started acting up on me. Anyone know whats up?
 
1 - 6 of 6 Posts
Top