Taurus Car Club of America : Ford Taurus Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I have a 2000 SEL with the 24v motor. It has 167k and runs like crap.... It misfires and surges... I have changes the plugs, fuel filter, camshaft sensor, crank sensor, upper and lower intake manifold gaskets ( the lower was leaking runs a little better but still misfires) the hose going to the pcv valve. I have swaped out the coils with others i had... The miss fires seem to move around and none of the coils seem to have enough power they all seem weak.... I don't know what to do next i have tried everything i have read in this forum to correct the misfires and general running like crap... I had the codes scaned mechanic said it was running lean in both banks and misfiring in cylinders 4 5 6 i swapped those coils and it still misfires.... Could it be the PCM??? I like the car but don't know what to do next.... Please help sometimes it comes out of it well driving and runs great for a few minutes then starts to stumble again
 

·
Registered
Joined
·
1,365 Posts
An ignition misfire can't cause a lean code. Excessive unburned fuel due to lack of spark will cause rich operation. Is this coil-on-plug?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
yes coil on plug.... i think the lean codes were do to the leak in the lower intake manifold gaskets but that is fixed now and i haven't had i scanned again.... and the car still misfires and runs like crap it surges and idles very rough....
 
1 - 4 of 4 Posts
Top