Taurus Car Club of America : Ford Taurus Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I've got a 1996 Ford Taurus that is having some sort of electrical problem. At first I thought it was the alternator but its a bit more complex. To make a long story short...


when I jump it, it stays running. When I take it off the jumper cables the dome lights turn on, the radio won't go off and something is clicking upnder the dash repeatedly and the car dies. When I take the keys out, it continues to do this until the batter is drained. Oh, when I started charging it for a jump today, without the keys in it the fan was going.


Any ideas? Where do I start?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
QUOTE (silvapain @ Mar 2 2009, 01:57 PM) index.php?act=findpost&pid=704630
Alternator. Low alternator voltage can cause a variety of weird/funny symptoms.[/b]
So would this cause everything to come on and stay on with no key in it? Nothing in the dash wants to work when this happens either. When I take if off the cables the all the gauges drop out and it starts to die. Is there any way to test the alternator without taking it out or going to a shop?
 

·
Premium Member
Joined
·
902 Posts
You battery is dead. The alternator is possibly causing it.

Disconnect your battery and put it on a charger overnight if you can. Then try to start the car with a fresh charged battery. It will probably behave for a while until the battery runs down again.
 

·
Registered
Joined
·
2,064 Posts
The fans sounds like a shot CCRM, rest of the stuff is possibly either a bad ground or very randomly, a shot MLP sensor. I doubt the sensor though.
 
1 - 6 of 6 Posts
Top