Taurus Car Club of America : Ford Taurus Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 1993 taurus sho 3.2L mtx. the car starts up great and runs great as long as i ease on the gas, once the pedal hits the floor it loses power. Like some thing turned the gas off. I have no check engine light or any problems that i have been able to find. Has any one had this problem before or know how to fix it?
 

·
Registered
Joined
·
1,047 Posts
Check your TPS (Throttle Position sensor) you may have a bad one, hook a volt meter up to the output of the sensor and monitor it when pressing on the gas (Car off) you should see a gradual increase in voltage. If there is spikeing or "Dead spots" you found your culprit.
 

·
Registered
Joined
·
5,820 Posts
You can still pull codes to see if you have any. The check engine light does not always come on if you have codes.

Also are the secondaries opening up?

Was any work doe recently?

How well does it idle?
 

·
Super Moderator
Joined
·
8,732 Posts
Hook up a fuel pressure gauge with a long hose and tape it to the windshield so you can see it while driving. At WOT, pressure should hold 39 psi. If it drops under high engine load (WOT), either the pump is weak. sock partly plugged, fuel filter partly plugged, etc.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Ok. tps is good, idles good, no work done, fuel pressure is about 32psi at idle and 40psi during acceleration. secondaries were no working properly due to bad vaccum line which is now repaired.

after further driving i noticed it does not lose power ony at WOT but if i open the throttle to fast it will cut out. i can get a nice acceleration if i really ease on the throttle but a little to fast and it will cuts out.

I am getting trouble code #33 which is most likely a bad egr valve. I cannot seem to locate it tho. could someone let me know where it is located? and any more advice is also appreciated.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #7 ·
I see the spot where the egr would mount but it is just a blank surface. I'm now assuming that I have a non egr intake. So now how do I explain the egr code?
 
1 - 7 of 7 Posts
Top