Taurus Car Club of America : Ford Taurus Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
HELLO,
I have had many issues with ignition modules over the yrs. Both GMC and FORD. I am current owner of a 1993 Taurus 3.0 Vulcan eight vin of "U" . I cannot find a good module replacement for it, The module just dies out when the vehicle gets to operation temp. FORD has discontinued their brand and am dealing with after market. If I stop and pull the ignition module out of the vehicle and spray it with "freeze it" and reinstall it will work for awhile until it gets to operation temp again. This happen no matter what brand I have used so far. Mostly cheap E-bay and Amazon. I did order one from Oreilys and it as the same issue.

TROY
 

·
Registered
Joined
·
26 Posts
Ask around with your friends, co-workers, local social network and find an electronics guy or gal for a little job. Circuit boards/motherboards/etc are cheaply made and can be repaired with a little solder applied at the right spots.
 

·
Super Moderator
Joined
·
8,008 Posts
I assume you have been using high quality heat sink thermally conductive grease when installing the modules? If not, they will overheat and fail every time for sure.

You can remote mount the TFI on a big heat sink, and even put a muffin fan on the heat sink for more cooling. Fairly common mod on 5.0 and 2.3 Turbo Mustangs and Thunderbirds. F150s from the mid / late 90s had remote mount TFIs on heat sinks. Could check the local JYs for one.
 
1 - 4 of 4 Posts
Top