Taurus Car Club of America : Ford Taurus Forum banner
1 - 20 of 30 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I've been told by the car shop that my car needs a computer. The first guy told me I need a section of the computer called an EOM or something like that and I was under the impression he could replace just that section.

The next guy I talked to (at the same shop, but on a different day) said I would have to have the whole computer replaced.

2 questions:
1. Do I HAVE to replace the whole computer if just one section is messed up?

and

2. Does $800 sound about right for replacing a computer?

Please advise, I've already spent $750 on this car to clear the diagnostic machine of all errors and it STILL doesn't run right and they said the computer is why.

TIA
 

·
Premium Member
Joined
·
17,415 Posts
What the heck...a 2006 needs a computer? Something sounds fishy.

What is the issue with the car? Do you have a check engine light or any lights/warning messages on? If so, go to AutoZone and get them to scan for the codes, and report back with the exact code.s Describe how the car doesn't run right.
 

·
Registered
Joined
·
1,392 Posts
Get another opinion at another shop before dishing out that much for a new ecm, that may or may not fix the problem.
 

·
Registered
Joined
·
3,377 Posts
computer tend to last years. a list of codes and symptoms will help. the shop should of gave you a list of the codes before clearing them out.
 

·
Premium Member
Joined
·
1,300 Posts
I suggest you to buy a scanner. The best way to seek repair tips on this board is to post codes. There are many semi and full professional members in this forum. You will recover the cost of scanner in just one or two repairs.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #6 · (Edited)
the car was misfiring a lot...I bought spark plugs and had them installed, but not new wires....car still misfired, but no engine light was coming on. I took it up to the shop I am currently using and they ran it on the machine and it came back saying I needed:

cam synchronizer
cam sensor
and they also said I needed new plugs and wires at which point I told them I already had new plugs in.

So I bought the above stuff ($513) and the machine showed NO errors. So I left the shop with my car and the car STILL ran like crap, so I turned around and took it back.

They spent a day uninstalling and reinstalling one of the cam things...said they might have to replace something to do with the cam...might have been bad out of the box, whatever....They also ran it on the machine again and suddenly I am showing a new error: bad speed sensor ($150)....so I picked my car up and took it for a drive and it drives MUCH better, still misfires occasionally, but overall a smoother ride...

except ever since they installed this new part I have an engine light on...and I called them up and ripped them a new one....I think its fishy I never had a light on before, only AFTER they worked on my car......so they kept my car and tried to figure out why this light is on and won't go off. They told me they think I need a new computer, but they said they keep some computer masters in Dallas on retainer so they paid to have these masters double check their work.....

the masters basically agreed with them and said if resetting my computer doesn't work then I will need a new one.

and that is where I'm at now. Before they said I needed a new computer, they were saying I might need a new transmission, since the engine machine showed no errors once I paid to have these parts installed which cleared previous errors. They said I bought a "bad" year model. I have now spent about $750, it still doesn't run right, although much better and I'm beside myself at this $800 which is just the part cost for a rebuilt computer, but not labor.

I will call them tomorrow to find out the specific code I am showing now.

thanks for the help

edit to add: I am scared that I will spend the $800 for this new computer and it won't fix the problem...like I said, the car still misfires occasionally and they had previously told me it may have something to do with my transmission...I will ask them about all this when I call tomorrow...at this point I am thinking maybe I will just take my chances with the car...they said I might be able to drive it for another 2 or 3 years like it is now or...maybe not. I will definitely try to get a second opinion.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #7 ·
sorry for the double post.

thank you, Bull Geek, for the Auto Zone tip....I just called them and it is FREE to scan my car :D ....I am going to take it up there today and will let ya'll know the result.
 

·
Premium Member
Joined
·
17,415 Posts
Oh my f(kdfjasdfjka god. Yes, RUN AWAY. What in the HECK are they doing to your car. They have absolutely zero idea what they are doing. The masters :rofl: What a load of....

Go here:
Car Talk | Mechanics Files

Search and find a better mechanic. Check on Google maps too, as people will review the places.

Be interested in hearing what AutoZone finds for codes...
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #11 ·
auto zone: P0340
cam sensor condition
probable cause:
1. defective
2. check connector end and wiring
3. engine mechanical condition- timing belt/chain


I'm pretty pissed ya'll considering I just supposedly had this replaced not 2 wks ago
 

·
Registered
Joined
·
3,377 Posts
a bad connection can cause that. or they didnt change it. There has been cases where the part was bad out of the box. If the sensor isnt seated correctly it will act like its bad. the shop you have been taking it to is a joke. the sensor should have a warranty. but that means you would have to take it back to the flunkies to have it done.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #13 · (Edited)
yes, i'm definitely gonna have to call them tomorrow and take it back up there. I just told my bro about my car problems and he is pretty pissed at me for not consulting him first. He said the place I took it to have turned into a bunch of high-priced crooks since Kelly-Tyler shut down. He said to take it up there, tell them I took it to Auto Zone, have them replace the sensor (again) and put the 'old' sensor in my hand. He said if they give me any hell then I need to tell them I will report them to the BBB.
(which, to me, isn't that big of a threat but whatever)

BiggDogg, when they replaced these parts and I suddenly had an engine light turn on, they said they would adjust my sensor. When that didn't work, they said they would take it out and reinstall it. Which they did (I guess)...they also said they might replace it....but they never told me if they actually did that or not...I assume they did not. I am still having a misfire, it was not driving great today, and my engine light is still on....which they said is because of my 'bad' computer....

so I will definitely have them replace it....it should be under warranty....and thank God they are closed today because I am so pissed I could spit nails....better to talk to them when I am not so irate.
 

·
Registered
Joined
·
3,377 Posts
i bet they just cleared the code and hoped it would go away or you would. A bigger threat is calling the news station. lol. if possible mark the sensor wires with a little bit of nail polish. that way when they hand you a sensor you will know if it was off your car. after all the parts got put in there should of never been a cel turning on. these guys just wanted to get paid for doing nothing.
 

·
Premium Member
Joined
·
17,415 Posts
Considering the importance of the sensor and the syncronizer (drives your oil pump), they had damn well not have fudged something up.

I like the nail polish idea...good idea Bigdogg. Or carve an innocent scratch into the black plastic.
 

·
Registered
Joined
·
3,377 Posts
Considering the importance of the sensor and the syncronizer (drives your oil pump), they had damn well not have fudged something up.

I like the nail polish idea...good idea Bigdogg. Or carve an innocent scratch into the black plastic.
i had a lady use it on a part i replaced on her tracker. she had gotten ripped of several times before and didnt trust anyone. she marked every part she could reach. i didnt notice it till she asked to see the old part. she was so happy that i did what i said i was going to do and got her tracker running right she took me to dinner after and told all her friends she found someone honest. it brought a lot of business and paid for my hunting trip that fall. :D
 

·
Registered
Joined
·
3,377 Posts
No problem. i hope everything gets sorted out and the car runs right for you. let us know how it goes. if you need anything else please let us know.
 
1 - 20 of 30 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top