Taurus Car Club of America : Ford Taurus Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
594 Posts
Discussion Starter #1
So, me & my mom went on a trip last weekend to Ichthus Festival in Wilmore, KY about an hour away, and she made me drive. I've driven the 'Style before, but this time it seemed like it had almost no power. We had to stop and get gas, so I checked the air filter, which was my first thought. It was disgusting, so when we got back it was replaced with a K&N, but it still seemed like it lacked power. It's not throwing any codes, so I'm basically clueless. Anything could be wrong with it since almost everything on that thing is electronic, right down to the throttle body, and I don't trust electronic components...

Any ideas?

EDIT: I picked up a new fuel filter for it since it's getting close to the 30k point, but I'm not really sure of the sevice interval for the fuel filter on the Freestyle.
 

·
Registered
Joined
·
594 Posts
Discussion Starter #2
Bump
 

·
Premium Member
Joined
·
7,048 Posts
QUOTE (Qwertz9586 @ Jun 20 2009, 09:58 PM) index.php?act=findpost&pid=733929
Fuel filters are to be changed every 12k miles.[/b]
Wow, that short?


The Taurus's fuel filter didnt get changed until ~110k IIRC. Of course, at that point, it would move NO fuel.
 

·
Registered
Joined
·
594 Posts
Discussion Starter #5
QUOTE (Qwertz9586 @ Jun 20 2009, 10:58 PM) index.php?act=findpost&pid=733929
Fuel filters are to be changed every 12k miles.[/b]
Well, that could very vell be the reason...

Well, I just replaced it, and I THINK it took care of the problem, but I won't know for sure until my mom drives it to work tomorrow, because I don't regularly drive it and I don't know exactly the way it's supposed to perform.

Also, the "universal" clips that come with new filters do NOT fit the Freestyle, so anyone attempting to do this in the future should try to refrain from breaking the originals.
 

·
Premium Member
Joined
·
15,922 Posts
1 - 6 of 6 Posts
Top