Taurus Car Club of America : Ford Taurus Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1 (Edited)
ok so i bought the car from an auction check engine light was not on (i assume since the car had to be jumped to get through the line) she is an 02 sable ls premium with 65k miles. check engine light started flashing i assumed the normal misfire and had her plugs wires and even the cylinder #4 fuel injector changed. still she was throwing p0304 and p0305 at me.

didnt even get to leave the mechanic and the CEL was on steady now and also flashing for the random misfire. i left her there. he did a compression test and it showed that cylinder number 4 was at about 100. so clearly there is a compression issue and there is a leak somewhere.my mechanic assumed my exhaust valves were dirty and just not seating correctly at low idle due to the condition of the motor and amount of miles he and i hope and highly doubt the valve is bent/burnt or has a broken ring. he removed the exhaust manifold (headers as some would say) and sprayed the valves with some seafoam and tried to clean em up. he said they were pretty caked up. (at least this is what he told me)

i tried running some seafoam through the throttle body (although half of it didnt make it in because i messed up) and that didnt work so i shall try this again

i put some marvel mystery oil in the motor and in the gas tank (i have only used about a 1/4 tank so far) light is still on

i even tried an old school mechanic trick someone told me and put some water in the throttle body in hopes of the steam cleaning the motor. light is still on.


im no mechanic but i would like to believe it is due to buildup on the valves seeing as the car runs flawless on the highway.

however when i get off the highway and sit at a red light she misfires and starts flashing. does not flash while on the highway only at low idle.

p0304 and p0305 are the only codes coming up period. there are no other codes stored or pending. i was told by another mechanic there are no vacume leaks as the car would be throwing lean codes at me

if i had a bent/burnt valve or bad ring wouldnt the car still misfire at higher speeds while on the highway?

please someone help before i throw any more money into this car.
 

·
Super Moderator
Joined
·
7,688 Posts
Coil pack.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4 (Edited)
LOOK AT THIS COIL PLEASE

so i posted another thread explaining my problem which you can read here

http://www.taurusclub.com/forum/87-engine-drivetrain/327786-02-duratec-3-0-24v-dohc-vin-s-low-idle-misfire.html

i pulled the coil to look at it myself after many people said its the coil pack and i even suspected it was the coil pack

my question now is.

is this coil bad? i dont see any cracks except one mark that looks more like a scratch. its very very faint and i tried my best in the pictures so you can see it.

also

i hear these motors are very specific when it comes to parts. i dont believe this is a motorcraft coil could that be my issue if it is the coil pack? could it be that scratch/crack?
( second to last picture is where you can attempt to see the very faint scratch/crack)
 

Attachments

·
Registered
Joined
·
9,609 Posts
Pic of Motorcraft coil cracks. If it is not MC, does not matter if it is cracked or not. Risky.

Plugs and plug wires must be top notch for "waste spark" systems as in coilpack.

-chart-
 

Attachments

·
Registered
Joined
·
8 Posts
Discussion Starter #6
Pic of Motorcraft coil cracks. If it is not MC, does not matter if it is cracked or not. Risky.

Plugs and plug wires must be top notch for "waste spark" systems as in coilpack.

-chart-
thanks for the pic. i have compared and come to the conclusion mine is not a motorcraft coil. i will be changing and updating very soon.
 

·
Has It Been That Long?
Joined
·
11,996 Posts
You can get a BWD coil as well; they're the OEM for Motorcraft on that part and by all accounts they still maintain the same quality.
 

·
Super Moderator
Joined
·
7,688 Posts
That coil pack is junk. A noted above, replace with Motorcraft or BWD.
 

·
Premium Member
Joined
·
1,522 Posts
You still have plugs and wires that can give you issues. Since you don't know the cars history who know how old those parts are.
 
1 - 12 of 12 Posts
About this Discussion
11 Replies
6 Participants
DPDISXR4Ti
Taurus Car Club of America : Ford Taurus Forum
A forum community dedicated to the Ford Taurus and SHO models, Mercury Sable and Lincoln MKS. Join the discussions on EcoBoost, aftermarket performance, and more!
Full Forum Listing
Top