Taurus Car Club of America : Ford Taurus Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,143 Posts
Discussion Starter · #1 ·
Hey everyone,

All of a sudden, I appear to be having trouble with my car. Friday, the car was running fine. It appears that on Saturday I bought a tank of bad fuel (watered down or something), as the car is running poorly (motor stumbling, poor idle) and the check engine light is on.

I have poured a bottle of fuel injector cleaner in the gas tank, and cleared the check engine light by pulling the battery cable off, and after 10 minutes of driving the motor was still stumbling and the light came back on.

Do you have any idea of what may be going on? The soonest that I can get into a ford dealer to have my codes pulled is Monday. It is odd that the car would just do this all of a sudden.

Thank you all for your assistance!
 
G

·
If you have an Autozone near you, they will pull your codes for free. I would do that, first to see when is going on then troubleshoot from there... I was going to suggest a bottle of injector cleaner/treatment, but you've already done that. If you really think it's bad gas, I'd just drive around trying to get rid of it, then when you get it about half gone or so, try filling up somewhere else to maybe try to dilute the bad gas. Hope this helps. :)
 

·
Registered
Joined
·
1,143 Posts
Discussion Starter · #3 ·
I went to Autozone where they pulled my codes for free and it returned
PO401, Insufficient EGR flow.

I was told that it is possible that the EGR valve is stuck, and I may need a
new one. I have an appointment at a Ford dealer on Monday, where I can get
a more accurate description. The car is one-month off of warranty, but I believe that they will work with me because it is still under 36,000 miles. At Autozone, the cost of a new EGR valve is $59.95.

It is odd that this would happen all of a sudden...any suggestions are welcome, and I will definately post the outcome on Monday.

Thank you all for your help!
 

·
Premium Member
Joined
·
3,449 Posts
Originally posted by Darthenstein@Jul 24 2004, 08:42 PM
I went to Autozone where they pulled my codes for free and it returned
PO401, Insufficient EGR flow.

I was told that it is possible that the EGR valve is stuck, and I may need a
new one. I have an appointment at a Ford dealer on Monday, where I can get
a more accurate description. The car is one-month off of warranty, but I believe that they will work with me because it is still under 36,000 miles. At Autozone, the cost of a new EGR valve is $59.95.

It is odd that this would happen all of a sudden...any suggestions are welcome, and I will definately post the outcome on Monday.

Thank you all for your help!
yup, its the EGR valve, a common problem with our cars. There is a warranty on the specific part, so it should be covered.

-Damon
 
G

·
Since you're getting that code (I had the exact same problem), just take it to the dealership and tell them what code you got and that you know there is a Technical Service Bulletin covering it and that it should be covered and to tell you before any additional costs are incurred. :)
 

·
Registered
Joined
·
1,143 Posts
Discussion Starter · #7 ·
Sounds good. I have the appointment at 8am tomorrow, so I will definately post the results. Thank you!
 

·
Registered
Joined
·
1,143 Posts
Discussion Starter · #8 ·
It was indeed the EGR pressure sensor, and the repair was covered by the extended factory warranty.

Thank you all for your assistance!
 
1 - 8 of 8 Posts
Top