Taurus Car Club of America : Ford Taurus Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Anyone ever have this happen...

The left rear coil spring broke and rubbed into the tire destroying it!

It happened when it was sitting in a parking lot and not driving. Didn't realize it until I got in to drive home and heard a grinding noise from tha back end, thought at firsat it might have been a brake dragging.

Does anyone know if there was a recall for this problem? I have heard that there was a similar problem with the front end, but not about the rear end.

Any help on this would be great!

Thankx
 

·
Premium Member
Joined
·
15,578 Posts
There was no recall for the rears, but there was one for the fronts. Try to get your Ford dealership to cover the damage, or put a call into Ford Corporate. Tell them that you've read in many posts on the internet that the rear springs are a problem as well, and that you want to get the damage covered.

They'll probably tell you to stick it up your ass, so you'll end up replacing them at your own cost.

Gen III SHO rear springs are good replacements, as they have a higher spring rate (155 lb/in as opposed to the Gen IV 120 lb/in) so you won't end up with saggy ass syndrome, like so many are apt to get.

JR
 

·
Premium Member
Joined
·
1,557 Posts
If you search the forum, it's quite a common thing to happen. Seems more so than than even the front springs breaking for which there is a recall. Mine went several months ago. I got Monroe Quick Struts. It's a much beefier spring and gets rid of the sagging. Think I'm going to get some for the front now too. I think mine went at about 80k. I happened to catch it before it destroyed the tire, but got a new one anyway as it had scraped a small groove in the sidewall, but it didn't touch the belt. That tire didn't have that much tread anyway so better safe than sorry.
 
1 - 6 of 6 Posts
Top