Taurus Car Club of America : Ford Taurus Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter · #1 ·
hey all,

i am having a prob. with my thermostat housing. i just had the heads redone on my 2000 3.0 vulcan non flex motor and put everything back together. I decided to replace the t-stat in the repair and got brand new gaskets and t-stat. I have the car all bolted up and put in radiator fluid and see that the t-stat housing is dripping and leaking when the car runs. I cleaned the bolts with a wire brush and lubed the threads and they sit flush.

I want to know what side of the t-stat the gasket goes on (neck or manifold) and what may be causing the leak?? The surfaces are clean and I can't figure this out??? It looks like the t-stat sits in the neck with the gasket behind it but it still drips radiator fluid..leaks more the other way... has anyone had this problem? Any fixes? Double gasket? please help because this is the last thing I need to finish to get my car back on the road!!! (and no leaks at the heads or anywhere else so this is REALLY bugging me!!)

Thanks!!
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #2 ·
Well,

got a new gasket and set the t-stat in while holding it in place and got it bolted all in...no leaks Guess the t'stat was out of alignment with the groove. :rolleyes2:
 

·
Registered
Joined
·
2,071 Posts
Well,

got a new gasket and set the t-stat in while holding it in place and got it bolted all in...no leaks Guess the t'stat was out of alignment with the groove. :rolleyes2:
I did the same thing once on my 97. changed the stat and it was leaking
after installation

In the process of putting the housing in place, the stat slipped slightly
and was slightly out of the grove. First clue should have been the bolts
did not feel quite right when i was tightening them. fired it up and it was leaking at the stat. took it off and re did it and all was well.
 
1 - 4 of 4 Posts
Top