Taurus Car Club of America : Ford Taurus Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-6 of 6 Results
  1. Taurus and Sable General Discussion
    I bought a new battery 2 weeks ago, and never noticed this scuffed up corner until today. I think I would have seen it when buying and installing. What could it be? The red color is terminal protector I sprayed after installing. I've not opened the cells or done anything else to it since...
  2. Maintenance and Repair
    My '96 Taurus GL, as it sits: The battery shows 12.7 volts. When I turn the key it just goes click. Recently replaced the Starter Motor and solenoid. Sometimes the teeth on the Starter spin, sometimes just a click. I have yet to hear them make contact with the Flywheel. I was told to use...
  3. Taurus and Sable General Discussion
    I have a 2005 Taurus ohv. It had random misfire and misfire within 1k codes. All new plugs, wires and a distributer later and now it is running even rougher then before, worse ever it has run, and is throwing just a misfire on 4 code. Checked plug and it was pretty fouled up already, replaced...
  4. Electronics, Security, Audio and Visual
    Hello, I have a 2004 Ford Taurus with the Vulcan Engine. In the morning my car cranks weak and slow. I did a parasite draw test but really didn't find anything. The closest thing I got was fuse #33 under the dash drawing 0.17-.19mV. But even that was just only one time that I measured it. I had...
  5. 5th and 6th Gen Maintenance and Repair
    So, two years ago, my beloved Taurus suffered a rack and pinion failure that took me a while to get repaired. Almost two years of fighting the wheel on the occasional trip I had to make for medical reasons, and because I was unable to work, was nigh-on impossible to afford to fix. Just lived...
  6. Maintenance and Repair
    I have a 2006 ford taurus, I changed the alternator about 3 weeks ago, charged the battery all has been good until today. I take my car a short 3 block trip down the road, started just fine ran good, came home went to leave again and my car wouldn't start at all....gauges clicking i know...
1-6 of 6 Results
Top