Taurus Car Club of America : Ford Taurus Forum - Search Results
Advanced Search
Showing results 1 to 8 of 8
Search took 0.01 seconds.
Search: Posts Made By: hulky
Forum: 5th and 6th Gen Electronics, Security, Audio and Visual   01-15-2019, 12:28 PM
Replies: 11
Views: 1,562
Posted By hulky
Leaning towards Scosche

Leaning towards Scosche
Forum: 5th and 6th Gen Electronics, Security, Audio and Visual   01-05-2019, 05:57 PM
Replies: 11
Views: 1,562
Posted By hulky
Sure, I'm checking it out on Crutchfield, thanks

Sure, I'm checking it out on Crutchfield, thanks
Forum: 5th and 6th Gen Electronics, Security, Audio and Visual   01-04-2019, 10:36 AM
Replies: 11
Views: 1,562
Posted By hulky
Any status on this? I have a 2010 SE with no...

Any status on this? I have a 2010 SE with no Sync, bluetooth or anything. It is pricey, but I would like to add bluetooth to my Taurus and this looks like an option.
Forum: 5th and 6th Gen Maintenance and Repair   12-07-2017, 12:05 AM
Replies: 6
Views: 542
Posted By hulky
Fixed

This is now fixed. The Long Term Fuel trims are 0 (Normal) and the codes are gone. Essentially I installed PART #: CRB 239183 Echlin Fuel injectors from Napa and they were causing the issue. Napa...
Forum: 5th and 6th Gen Maintenance and Repair   11-30-2017, 05:44 AM
Replies: 6
Views: 542
Posted By hulky
I may not have all the answers to your questions...

I may not have all the answers to your questions but my multimeter read #5 Injector as totally dead, while the others were reading around 14.1 ohms.

I think I saw a video from Scotty Kilmer that...
Forum: 5th and 6th Gen Maintenance and Repair   11-29-2017, 11:52 AM
Replies: 6
Views: 542
Posted By hulky
Well the good news is the Pending P0150...

Well the good news is the Pending P0150 disappeared. The bad news is now I have a confirmed

P2198: O2 Sensor Signal Biased/Stuck Rich Bank 2 Sensor 1

Ordered an O2 sensor from Amazon, figured...
Forum: 5th and 6th Gen Maintenance and Repair   11-29-2017, 09:28 AM
Replies: 6
Views: 542
Posted By hulky
Firing the parts canon but no love

I have been firing the parts canon on this Taurus for 2 months now and it isn't working. After replacing 6 Spark plugs, 3 Ignition Coils and 4 Fuel injectors what do I do now? Replace the 02 sensor? ...
Forum: Introduction Forum   11-28-2017, 07:15 AM
Replies: 4
Views: 228
Posted By hulky
New Sixth generation Taurus Owner in Atlanta!

Hey, I'm a New Sixth generation Taurus Owner in Atlanta! Not the 1st Ford I've owned but now coming over from a Buick LeSabre.
Showing results 1 to 8 of 8

 
Forum Jump
 
For the best viewing experience please update your browser to Google Chrome