Taurus Car Club of America : Ford Taurus Forum - Reply to Topic
Thread: What Have You Done To Your Bull Today? Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-09-2019 02:48 PM
Dappersworth Fixed the right tweeter! I had somehow forgotten to connect a power wire to the whole bundle of wires. Have some pictures!
08-08-2019 09:13 PM
Dappersworth Just installed the mach audio tweeters and rcu, my radio (i think) no longer dims with the beat of the bass! Also, the right tweeter doesn't work, as far as I can hear, not sure why.
07-31-2019 09:15 PM
Dappersworth Honestly I'm not even sure my synchro is going bad, the squeaking sounds more like a bearing for one of the serpentine belt pulleys. It doesnt sound like an actual bird, it's a bit less high pitched. As for the maf sensor, it's for the running rich problem I'm having. But theres a high pitched whining coming from the underside of the right side of the car around the middle, could that just be the fuel pump? Brother thinks it's a vaccum leak.
07-31-2019 06:28 PM
Automender12345
Quote:
Originally Posted by Dappersworth View Post
Also found these on amazon. Wondering if the maf sensor is *too* cheap, the brand is Partschoice.

I would be worried about the Cam Sychro. I wouldn't use a unknown name to drive my oil pump, the life blood of my engine.
07-31-2019 03:46 PM
mcsteven
Quote:
Originally Posted by Dappersworth View Post
Rotated my tires and fixed (hopefully) a transmission leak, noticed it when I looked under the car after moving it to a flatter surface. Idled the car again after adjusting a few bolts and didn't see any leakage.
Picture of car included because why not? Haven't posted a picture yet. Best color in my opinion.


For the third and fourth generation sedans I do like the silver. I prefer the blue for the wagon.


Sent from my iPhone using Tapatalk
07-30-2019 08:13 PM
Dappersworth Also found these on amazon. Wondering if the maf sensor is *too* cheap, the brand is Partschoice.
07-30-2019 08:06 PM
Dappersworth Rotated my tires and fixed (hopefully) a transmission leak, noticed it when I looked under the car after moving it to a flatter surface. Idled the car again after adjusting a few bolts and didn't see any leakage.
Picture of car included because why not? Haven't posted a picture yet. Best color in my opinion.
07-30-2019 04:03 PM
mcsteven Ok, it wasnít today. It started on Sunday the 21st and ended Sun the 28th. I drove it cross country from Oakland, CA to Middletown, CT.

Around town I was getting 15-16.5 mpg. Check out the highway mileage! The 22 & 23 were before I realized that the low grade in Utah, Wyoming, and more was 85 octane.

So, any Connecticut area members? Iíve moved (back) here.


Sent from my iPhone using Tapatalk
07-30-2019 03:55 PM
mcsteven
Quote:
Originally Posted by sheila View Post
^ And fwiw, I'm also leary of the "multi-vehicle" atf.


Me as well.


Sent from my iPhone using Tapatalk
07-30-2019 03:41 PM
sheila ^ And fwiw, I'm also leary of the "multi-vehicle" atf.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

 
For the best viewing experience please update your browser to Google Chrome