Cruise Control Mystery - Taurus Car Club of America : Ford Taurus Forum
 4Likes
  • 4 Post By Andrei
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 04-20-2019, 11:18 AM Thread Starter
Junior Member
 
Join Date: May 2016
Location: Tampa
Chapter: Southeast
Year: 2004
Model: Ford Taurus
Engine: 3.0L 12v Vulcan V6
Posts: 62
Rep Power: 7
 
Trader Score: 0 reviews
Solved! Cruise Control Mystery - worth reading

Hi guys,


2004 Taurus, Vulcan engine. I saw that cruise doesn't engage (cruise light doesn't come on either), but I don't know for how long it's been like this, since I haven't tried to use cruise control in a few months.
Also, I tried the self-test
. Light blinks correctly (which confirms that steering wheel buttons are working, and the dash light works), but the pedal doesn't move at all at the end, like it's supposed to (see video)

What I did, to no avail:
- checked all fuses (couldn't find which one exactly, so I checked them all!). No blown fuse.

- replaced cruise switch on the brake pedal. No change.
- Brake lights switch is almost new (all brake lights work correctly)

- I got a cruise control module from the JY (big discount today), with the cable. No change.
- There is no CEL and no stored code. Nothing else wrong with the car, just cruise not working.
Ideas, please?
Thanks!

Last edited by Andrei; 04-21-2019 at 03:12 PM. Reason: Updating information
Andrei is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-21-2019, 03:20 PM Thread Starter
Junior Member
 
Join Date: May 2016
Location: Tampa
Chapter: Southeast
Year: 2004
Model: Ford Taurus
Engine: 3.0L 12v Vulcan V6
Posts: 62
Rep Power: 7
 
Trader Score: 0 reviews
UPDATE (and closure) for future visitors of this thread.

So, after I checked all the wires possible, tried my JY module on my father in law's car (it worked), there was nothing left. Everything was in order but cruise still didn't work. It had already been a week of research and replacing parts. UNTIL I read a random thing online that opened my eyes: back in November I had replaced my brake lights with LED bulbs. In order to avoid installing the ballast, I just found a relay that works with LED bulbs, to prevent hyper-flashing.
THAT was what kept my cruise from engaging. The LED bulbs weren't drawing enough power, and the computer read it as if I had blown bulbs, and wouldn't engage the Cruise Control. Replaced with regular bulbs for testing and it works just fine!
Will install resistors, because I want to keep the LED's but this was a very interesting problem...

Last edited by Andrei; 04-21-2019 at 09:52 PM. Reason: Spelling
Andrei is offline  
post #3 of 3 (permalink) Old 05-13-2019, 10:36 AM Thread Starter
Junior Member
 
Join Date: May 2016
Location: Tampa
Chapter: Southeast
Year: 2004
Model: Ford Taurus
Engine: 3.0L 12v Vulcan V6
Posts: 62
Rep Power: 7
 
Trader Score: 0 reviews
UPDATE2: Installed resistors. Cruise works just fine UNTIL I use my blinkers when I change lanes. Then it turns off. The second I turn on the blinker, cruise disengages. I admitted defeated and I switched back to regular brake lights
Andrei is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Any other ideas for cruise control issue... jasen Maintenance and Repair 6 02-07-2019 08:30 AM
Inoperative Cruise Control Diagnose pawpaw Maintenance and Repair 25 03-07-2018 09:36 PM
Cruise control not working-has me stumped gska3873 Maintenance and Repair 0 07-08-2014 07:33 PM
2006 Taurus SE Cruise Control Not Working Nilrem Maintenance and Repair 3 01-26-2014 12:33 PM
Cruise control question NyteFire Electronics, Security, Audio and Visual 2 04-16-2013 10:44 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome