taurus transmission in limp mode? - Page 2 - Taurus Car Club of America : Ford Taurus Forum
Reply
 
LinkBack Thread Tools
post #11 of 11 (permalink) Old 04-26-2014, 09:07 AM
Junior Member
 
Join Date: Apr 2014
Location: rouses point NY
Chapter: Northeast
Posts: 36
Rep Power: 0
 
Trader Score: 0 reviews
Quote:
Originally Posted by 4 wheel disc brakes View Post
The 2000 rpm hunt in P and N is an RPM limiter.
No power transfer in all forward gears, and R is likely a pump, pump shaft or torque converter spline failure.
Check the fluid level after it sits over night. (It should be above the full mark). Check it again after running through the gears. If the fluid level remains high, the fluid pump isn't working.

should be 4000 rpm for the limiter

2000 Taurus SES "Classic Edition" - the unpolished TURD
shapeshifter is offline  
Sponsored Links
Advertisement
 
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Official Northeast Chapter Member Information TaurusDailyDriver Northeast Chapter Forum 1 06-27-2014 11:01 PM
Digital Transmission Range Sensor on 99 Taurus BryanCookson Engine and Drivetrain 10 01-16-2014 01:53 PM
transmission intercooler form gen2 for gen3 taurus jc_oo5 Engine and Drivetrain 4 12-31-2013 12:19 PM
96 taurus ax4s only moves after transmission warms up asmsalem Maintenance and Repair 14 07-16-2013 01:03 AM
1992 Taurus Wagon transmission mystery mroberts11 Maintenance and Repair 3 06-15-2013 10:28 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome