Battery light - Taurus Car Club of America : Ford Taurus Forum
 2Likes
  • 1 Post By chartmaker
  • 1 Post By Hornswaggle
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 08-03-2019, 02:52 PM Thread Starter
Member
 
Join Date: Jun 2010
Location: Minnesota
Chapter: Midwest
Year: 2004
Model: Mercury Sable
Engine: 3.0L 24v Duratec V6
Posts: 463
Rep Power: 19
 
Trader Score: 1 reviews
Battery light

'02 duratec


Battery light is on and I'm having trouble finding the cause. Battery voltage is 12.7 and goes up to 14.3 when engine is running so I believe both battery and alternator are okay. I've cleaned battery terminals and ground terminals on fender and firewall. Anybody have a suggestion what else it could be?

Kevin

Current stable
2004 Sable LS Prem DOHC
2003 Taurus SES Vulcan
2002 Taurus SES DOHC

Retired:
2001 Taurus SES DOHC
2000 Taurus SE Vulcan
1994 Sable GS
1988 Taurus LX
Hornswaggle is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-04-2019, 09:52 AM
Moderator
 
Join Date: Feb 2007
Location: Milwaukee, WI
Chapter: Midwest
Year: 2005
Model: Ford Taurus
Engine: 3.0L 24v Duratec V6
Posts: 7,659
Rep Power: 87
     
Trader Score: 0 reviews
Voltage regulator?

05 Taurus SEL Duratec - my daily driver
04 Taurus SES Duratec - wifes car - TOTALED
06 Taurus SE Vulcan - wifes new ride
95 Taurus GL Vulcan winter car
Toy #1 - 86 Tbird 5.0 (original owner) - LOTS of mods
Toy #2 - 88 Tbird Turbo Coupe - LOTS of mods
67 Honda 450 Super Sport - completely customized
Jeff K is offline  
post #3 of 5 (permalink) Old 08-05-2019, 10:03 AM Thread Starter
Member
 
Join Date: Jun 2010
Location: Minnesota
Chapter: Midwest
Year: 2004
Model: Mercury Sable
Engine: 3.0L 24v Duratec V6
Posts: 463
Rep Power: 19
 
Trader Score: 1 reviews
I think the regulator is built into the alt but it seems to be working if the charging voltage is 14.3. I rechecked the ground points on fender and firewall and even cleaned the connections on the mega fuse. I loaded it down with lights and accesories on while running and the voltage only fluctuated .1v. I'll get underneath and check the plug and cable connections next. I've got another alt I saved from a different car but changing them out on a DOHC is not what I call a fun time. Anybody run into a similar situation with good voltage readings but alt was still bad?


- forgot to add that I am not getting any trouble codes.

Kevin

Current stable
2004 Sable LS Prem DOHC
2003 Taurus SES Vulcan
2002 Taurus SES DOHC

Retired:
2001 Taurus SES DOHC
2000 Taurus SE Vulcan
1994 Sable GS
1988 Taurus LX

Last edited by Hornswaggle; 08-05-2019 at 10:32 AM.
Hornswaggle is offline  
 
post #4 of 5 (permalink) Old 08-05-2019, 10:41 AM
Crazy Devoted Member
 
Join Date: May 2011
Location: NY State
Chapter: Northeast
Year: 2003
Model: Mercury Sable
Engine: 3.0L 24v Duratec V6
Posts: 9,601
Rep Power: 99
      
Garage
Trader Score: 0 reviews
Quote:
Originally Posted by Hornswaggle View Post
I think the regulator is built into the alt but it seems to be working if the charging voltage is 14.3. I rechecked the ground points on fender and firewall and even cleaned the connections on the mega fuse. I loaded it down with lights and accesories on while running and the voltage only fluctuated .1v. I'll get underneath and check the plug and cable connections next. I've got another alt I saved from a different car but changing them out on a DOHC is not what I call a fun time. Anybody run into a similar situation with good voltage readings but alt was still bad?


- forgot to add that I am not getting any trouble codes.
If you have '01 Alt on '02 and later the charging light will be always on. Been there. See table the '01 and earlier use the gray body regulator and '02 and later use the white "PCM" control regulator. Upper part of sheet, 4G series for DOHC. Black body used on V-8 engines with the same Alt.


Color of body of regulator not part number is the determining visual.


-chart-
Attached Thumbnails
Click image for larger version

Name:	Regulator3.jpg
Views:	20
Size:	260.5 KB
ID:	209321  
kekaye56 likes this.
chartmaker is offline  
post #5 of 5 (permalink) Old 08-05-2019, 11:40 AM Thread Starter
Member
 
Join Date: Jun 2010
Location: Minnesota
Chapter: Midwest
Year: 2004
Model: Mercury Sable
Engine: 3.0L 24v Duratec V6
Posts: 463
Rep Power: 19
 
Trader Score: 1 reviews
Chart you are a genius, I bet that is the problem! I'll check tonight.
kekaye56 likes this.

Kevin

Current stable
2004 Sable LS Prem DOHC
2003 Taurus SES Vulcan
2002 Taurus SES DOHC

Retired:
2001 Taurus SES DOHC
2000 Taurus SE Vulcan
1994 Sable GS
1988 Taurus LX
Hornswaggle is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
15% discount for a Battery Tester! Topdon_Patrick Vendors and Group Buys 1 10-11-2018 11:00 PM
15% off for Battery Tester! Topdon_Patrick Vendor Deals 0 08-08-2018 04:42 AM
200 Ford Taurus SES U Engine, Battery Light Saga connordo Maintenance and Repair 0 07-08-2015 07:30 PM
Check Engine light: Check the battery! Brcobrem Maintenance and Repair 10 07-16-2014 02:00 PM
Battery Light on ohio_grad_06 Maintenance and Repair 22 05-27-2014 08:29 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome