02 Mercury Sable Misfire problems - Taurus Car Club of America : Ford Taurus Forum
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 04-24-2019, 11:57 AM Thread Starter
Junior Member
 
Join Date: Apr 2019
Posts: 2
Rep Power: 0
 
Trader Score: 0 reviews
02 Mercury Sable Misfire problems

Hello, I own a 2002 Mercury sable. Had it parked outside and had a bad snow storm this winter, when i got it running again, i opened the hood and there was snow that had drifted all up in the engine bay on the right side air filter side. Right after that I had my Check Engine Light start flashing on me and by the time i almost had it home, it slowly started to weaken up. About a mile or so from home, the engine rpm wouldn't go higher then a certain point and couldn't go faster than 20 mph with a quiet sounding engine rev. I changed the spark plugs which were already pretty new. Changed the spark plug wires and the coil pack and still nothing. I did the ear test on the fuel injectors and they all seemed to be working. Car sounded like the muffler had water in it so maybe catalytic converter? Anything else anyone has tried with misfires? Thanks
Richard LaFernier is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-24-2019, 01:03 PM
Play Nice or Don't Play

 
jag1959's Avatar
 
Join Date: Jun 2011
Chapter: Northeast
Year: 1998
Model: Ford Taurus SHO
Engine: 3.4L Yamaha V8
Posts: 14,705
Rep Power: 120
       
Trader Score: 0 reviews
An active misfire can kill a cat in minutes. Has the misfire itself been resolved?

It's SHO time!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jag1959 is offline  
post #3 of 3 (permalink) Old 04-24-2019, 01:17 PM
Junior Member
 
Join Date: Oct 2017
Location: Lakewood, CO
Chapter: West Coast
Year: 2006
Model: Ford Taurus
Engine: 3.0L 12v Vulcan V6
Posts: 50
Rep Power: 4
 
Trader Score: 0 reviews
did you have the codes read for your check engine light?
Cfella is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
I think my engine may have been swapped. My vin # seems to think so. Chiller449 Engine and Drivetrain 57 02-18-2016 06:54 PM
2004 Mercury Sable random misfire Jessesbeck Maintenance and Repair 18 09-13-2015 12:57 PM
Brake problems 94 Mercury Sable Mikejustis6 Introduction Forum 2 04-13-2015 01:31 PM
Misfire Diagnosis Using Mode $06 (Advanced) Sam Maintenance and Repair 14 06-02-2014 12:24 PM
How to Understand and Diagnose Misfires Sam Solutions to Common Problems and 'How To' Articles 0 11-12-2012 02:37 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome