Strange A/C Charging Port H Side - Page 2 - Taurus Car Club of America : Ford Taurus Forum
 7Likes
Reply
 
LinkBack Thread Tools
post #11 of 15 (permalink) Old 04-04-2019, 12:22 PM Thread Starter
Junior Member
 
Draco911's Avatar
 
Join Date: Mar 2019
Location: Rancho Palos Verdes
Chapter: West Coast
Year: 1996
Model: Ford Taurus Wagon
Engine: 3.0L 24v Duratec V6
Posts: 43
Rep Power: 0
 
Garage
Trader Score: 0 reviews
Oh perfect, that will help :-)


Any tips or tricks besides the Crowsfoot?

Draco

Last edited by Draco911; 04-04-2019 at 12:30 PM.
Draco911 is offline  
Sponsored Links
Advertisement
 
post #12 of 15 (permalink) Old 04-04-2019, 01:26 PM
Crazy Devoted Member
 
Join Date: Dec 2006
Chapter: Midwest
Year: 1998
Model: Mercury Sable
Engine: 3.0L 24v Duratec V6
Posts: 21,992
Rep Power: 111
     
Trader Score: 1 reviews
Draco, your hi port pic looks exactly like the new 1 I have in the cellar with the black seal. If it's leaking, swap it.
boulderdentist likes this.
sheila is offline  
post #13 of 15 (permalink) Old 04-04-2019, 02:25 PM
Crazy Devoted Member
 
Join Date: Jan 2010
Location: North Canton, Ohio
Chapter: Midwest
Year: 2006
Model: Ford Taurus
Engine: 3.0L 12v Vulcan V6
Posts: 6,368
Rep Power: 63
    
Trader Score: 0 reviews
Quote:
Originally Posted by Draco911 View Post
Thanks again Fellas,


Yeap, will be doing a port swap with new valve. Probably new expansion valve as well as when I tried to charge the system, High Side only went up to 40PSI. Low side was way too high


TIA,


J

I think you have things mixed up. You can't really have a low side higher that the high side. A high high side and low low side can be an orifice tube plugged. If what you say is true then you need to rethink what is wrong. You have some sort of low side restriction which is hard to believe.


Remember to evacuate the system.
Attached Thumbnails
Click image for larger version

Name:	f1634051.jpg
Views:	3
Size:	139.1 KB
ID:	208417   Click image for larger version

Name:	f1634627.jpg
Views:	4
Size:	157.6 KB
ID:	208419  

Last edited by Automender12345; 04-04-2019 at 02:29 PM.
Automender12345 is online now  
 
post #14 of 15 (permalink) Old 04-04-2019, 07:03 PM
Member
 
Join Date: Sep 2014
Chapter: Midwest
Year: 02
Model: Ford Taurus
Engine: 3.0L 12v Vulcan V6
Posts: 132
Rep Power: 10
 
Garage
Trader Score: 0 reviews
Quote:
Originally Posted by Draco911 View Post
Oh perfect, that will help :-)


Any tips or tricks besides the Crowsfoot?
There is a special socket that fits the high side port. (8 sided)
rsteve56 is offline  
post #15 of 15 (permalink) Old 04-04-2019, 09:11 PM
Crazy Devoted Member
 
Join Date: Dec 2006
Chapter: Midwest
Year: 1998
Model: Mercury Sable
Engine: 3.0L 24v Duratec V6
Posts: 21,992
Rep Power: 111
     
Trader Score: 1 reviews
^+1. I've also got the lo and hi port sockets in the cellar, lol. Before purchasing the sockets, iirc, I used a small crescent wrench, pliers or vise-grips to swap the service ports.

Last edited by sheila; 04-04-2019 at 09:14 PM.
sheila is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Single port A/C charging 46davis Maintenance and Repair 7 08-13-2018 01:24 PM
Locate HVAC Low Side Port RonT Maintenance and Repair 1 05-19-2018 07:42 AM
1998 Taurus - 12 valve OHV AC low side is low, high side is low fabsroman Maintenance and Repair 2 06-07-2015 09:31 AM
Impossible to connect (ac manifold gauge) to low side port (2004 Taurus) TheEgg Maintenance and Repair 3 07-10-2014 08:33 PM
High Side Port Leaking?? bull geek Maintenance and Repair 13 09-15-2013 10:51 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome