Inner Tie Rod Came Loose... - Taurus Car Club of America : Ford Taurus Forum
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 01-17-2009, 10:28 AM Thread Starter
Crazy Devoted Member
 
Join Date: Nov 2002
Location: Chatham, Ontario
Chapter: Eastern Canada
Posts: 5,179
Rep Power: 0
 
Trader Score: 0 reviews
So to expand on my thread in the NAIAS thread.

I was driving and luckily was off the freeway when this happened. My Inner tie rod came undone.

After investigating and having the part off the car, I notice the the roll pin that i hammered in when i installed it, had worked its way loose. What should I do about this? I mean clearly hammering it back in is going to give me a false sense of security, as if it worked its way out once, after being reinstalled and and hammered in again, its going to be even looser. Should I use some blue or red thread locker on it? I mean I really do not want to be in this situation again, heaven forbid it happen when I am on the highway next time.



zeptoplix is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 01-17-2009, 10:45 AM
Devoted Member
 
DaveX 3.0's Avatar
 
Join Date: Oct 2007
Location: Methuen, MA
Chapter: Northeast
Posts: 1,318
Rep Power: 26
 
Trader Score: 0 reviews


That cannot be a good feeling it all.

Did you check all the threads and make sure none of them were damaged?

I'm assuming that this roll pin you're talking about was to help hold the end that threads onto the rack in place, correct? The inner tie rods I put on my car never had any kind of roll pins or set screws or anything like that, and the OEM ones I had pulled off the car didn't have anything either.

Currently driving a 2009 Focus SE Sedan w/5-Speed!

Previous cars:
1997 Geo Prizm
1996 Ford Taurus G

Formerly "Mr. X"
DaveX 3.0 is offline  
post #3 of 3 (permalink) Old 01-17-2009, 10:52 AM Thread Starter
Crazy Devoted Member
 
Join Date: Nov 2002
Location: Chatham, Ontario
Chapter: Eastern Canada
Posts: 5,179
Rep Power: 0
 
Trader Score: 0 reviews
I was able to reinstall it, and it threaded right back on no problem. All of these inners i have installed on the car have had a pin of some sort.


zeptoplix is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome