Rough This Morning - Taurus Car Club of America : Ford Taurus Forum
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 12-20-2008, 03:25 PM Thread Starter
Junior Member
 
Join Date: Nov 2008
Posts: 53
Rep Power: 0
 
Trader Score: 0 reviews
My wife 2000 sable wagon with the duratec ran really rough this morning , but was fine once it warmed up.
I looked down to see the check engine light on. Went to autozone and got this code p1151.
Autozone was not much help, Any ideas.
thanks
webbrook is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 12-20-2008, 03:36 PM
Crazy Devoted Member
 
spridget's Avatar
 
Join Date: Nov 2002
Location: In a shed, doing maths
Posts: 9,959
Rep Power: 0
 
Trader Score: 0 reviews
Send a message via Yahoo to spridget
Quote:
My wife 2000 sable wagon with the duratec ran really rough this morning , but was fine once it warmed up.
I looked down to see the check engine light on. Went to autozone and got this code p1151.
Autozone was not much help, Any ideas.
thanks
[/b]
How many miles? How has it been maintained?

P1151 Lack Of Upstream HO2S Switch, Sensor Indicates Lean, Bank No. 2

RIP TCCA

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'96 ES SHO -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
-
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
-
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

spridget is offline  
post #3 of 6 (permalink) Old 12-20-2008, 03:41 PM
Senior Member
 
Join Date: Apr 2008
Location: Temple/Houston, Texas
Posts: 987
Rep Power: 0
 
Trader Score: 0 reviews
Quote:
<div class='quotemain'>
My wife 2000 sable wagon with the duratec ran really rough this morning , but was fine once it warmed up.
I looked down to see the check engine light on. Went to autozone and got this code p1151.
Autozone was not much help, Any ideas.
thanks
[/b]
How many miles? How has it been maintained?

P1151 Lack Of Upstream HO2S Switch, Sensor Indicates Lean, Bank No. 2
[/b][/quote]
OMG getting advice from the king himself. legendary



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

<strike>1997 Ford Taurus Bodacious Edition</strike>
TCCA South

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2008 M6 I4
blackmagic3920 is offline  
 
post #4 of 6 (permalink) Old 12-20-2008, 04:10 PM
Junior Member
 
Join Date: Mar 2008
Posts: 9
Rep Power: 0
 
Trader Score: 0 reviews
Quote:
My wife 2000 sable wagon with the duratec ran really rough this morning , but was fine once it warmed up.
I looked down to see the check engine light on. Went to autozone and got this code p1151.
Autozone was not much help, Any ideas.
thanks
[/b]
90% of the time its the PCV system. I don't know if the 2000 is different than our '98 Duratec Sable ,but the elbow that receives the PCV valve swelled and didn't provide a airtight seal and it threw same code and ran rough
cold with misfire under load. Threw a clamp on the joint making sure the PCV is seated before tightening.
It's not the easiest clamp install (2 extensions on my 1/4" ratchet) but it was easier than taking the UM
off and r/r suspect rubber elbows and hoses.

Best of luck,
MustangScott
escotland is offline  
post #5 of 6 (permalink) Old 12-20-2008, 04:29 PM Thread Starter
Junior Member
 
Join Date: Nov 2008
Posts: 53
Rep Power: 0
 
Trader Score: 0 reviews
Quote:
<div class='quotemain'>
My wife 2000 sable wagon with the duratec ran really rough this morning , but was fine once it warmed up.
I looked down to see the check engine light on. Went to autozone and got this code p1151.
Autozone was not much help, Any ideas.
thanks
[/b]
90% of the time its the PCV system. I don't know if the 2000 is different than our '98 Duratec Sable ,but the elbow that receives the PCV valve swelled and didn't provide a airtight seal and it threw same code and ran rough
cold with misfire under load. Threw a clamp on the joint making sure the PCV is seated before tightening.
It's not the easiest clamp install (2 extensions on my 1/4" ratchet) but it was easier than taking the UM
off and r/r suspect rubber elbows and hoses.

Best of luck,
MustangScott
[/b][/quote]

Car has 144,000 miles on it and has been maintain well.
Pcv valve and hose are new as well as the other vacuum lines that usaully rot away.
webbrook is offline  
post #6 of 6 (permalink) Old 12-20-2008, 05:36 PM
Crazy Devoted Member
 
spridget's Avatar
 
Join Date: Nov 2002
Location: In a shed, doing maths
Posts: 9,959
Rep Power: 0
 
Trader Score: 0 reviews
Send a message via Yahoo to spridget
Have the O2 sensors ever been replaced?

RIP TCCA

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'96 ES SHO -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
-
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
-
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

spridget is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome