Power Steering Fluid Filter - Page 3 - Taurus Car Club of America : Ford Taurus Forum
 1Likes
Reply
 
LinkBack Thread Tools
post #21 of 28 (permalink) Old 06-29-2016, 02:46 AM Thread Starter
Devoted Member
 
Join Date: Apr 2003
Location: Virginia
Chapter: Southeast
Year: 94
Model: Ford Taurus
Engine: 3.8L Essex
Posts: 2,433
Rep Power: 44
 
Trader Score: 0 reviews
Bump:
Well here it is 2016 & the 94 Taurus & 99 Ranger power steering systems are still doing fine, no return of off center loss of boost, or shudder on either vehicle After installing a Magnefine inline filter in their power steering return line 8 years ago.
It's time to replace them & when I do I'll open them up & post photos of anything the filter media, or magnet has captured. The fluid in both systems is still clear red.

94 Taurus GL 3.8L PEP204A
99 Ranger XLT 4dr 4.0L 5spd Auto
Payload & Tow Pkg

Details are trifles, but trifles make perfection & perfection is no trifle (Ben Franklin)
Our signature is a sign of a job completed, autograph your work with excellence.

Last edited by pawpaw; 10-17-2016 at 11:57 AM.
pawpaw is offline  
Sponsored Links
Advertisement
 
post #22 of 28 (permalink) Old 06-29-2016, 08:18 AM
Crazy Devoted Member
 
Join Date: May 2011
Location: NY State
Chapter: Northeast
Year: 2003
Model: Mercury Sable
Engine: 3.0L 24v Duratec V6
Posts: 9,508
Rep Power: 99
      
Garage
Trader Score: 0 reviews
Quote:
Originally Posted by pawpaw View Post
Bump:
Well here it is 2016 & the 94 Taurus & 99 Ranger power steering systems are still doing fine, no return of off center loss of boost, or shudder on either vehicle After installing a Magnefine inline filter in their power steering return line. It's time to replace them & when I do I'll open them up & post photos of anything the filter media, or magnet has captured. The fluid in both systems is still clear red.
I suck out the fluid from the resivor each fall and replace it. Takes maybe a pint. Stays clean, never had a PS issue: 8 Bulls, 5 Lin Cont.

Well, not never, had a seal leak on '01 and put a new shaft seal in. Car sold. = '01 DOHC. 131K

-chart-
chartmaker is offline  
post #23 of 28 (permalink) Old 10-10-2016, 01:32 AM
Junior Member
 
Join Date: Sep 2013
Location: Lakeland FL
Chapter: Southeast
Posts: 48
Rep Power: 0
 
Trader Score: 0 reviews
What is this cylinder? Is this a power steering filter, too?
Attached Thumbnails
Click image for larger version

Name:	PicsArt_10-10-02_1476081103296.31.25.jpg
Views:	361
Size:	152.7 KB
ID:	181978  
thecraze is offline  
 
post #24 of 28 (permalink) Old 10-14-2016, 12:21 PM Thread Starter
Devoted Member
 
Join Date: Apr 2003
Location: Virginia
Chapter: Southeast
Year: 94
Model: Ford Taurus
Engine: 3.8L Essex
Posts: 2,433
Rep Power: 44
 
Trader Score: 0 reviews
Quote:
Originally Posted by thecraze View Post
What is this cylinder? Is this a power steering filter, too?
Look on page 2, post 18 of this thread, for the factory power steering filter location & what it & the Magnefine filters look like.

94 Taurus GL 3.8L PEP204A
99 Ranger XLT 4dr 4.0L 5spd Auto
Payload & Tow Pkg

Details are trifles, but trifles make perfection & perfection is no trifle (Ben Franklin)
Our signature is a sign of a job completed, autograph your work with excellence.
pawpaw is offline  
post #25 of 28 (permalink) Old 10-14-2016, 02:29 PM
Senior Member
 
Join Date: Jun 2010
Location: CA
Chapter: West Coast
Year: 2004
Model: Ford Taurus
Engine: 3.0L 24v Duratec V6
Posts: 543
Rep Power: 21
 
Trader Score: 0 reviews
Don't forget to inspect and clean the mesh "filter" screen at the bottom of the reservoir.

2004 Taurus SES Duratec 107k

Upgrades: Mach RCU & Tweeters, Bluetooth, Ford Cargo Tray, LED Trunk Lighting, Headlight Relays, Adjustable Pedals
Running on: Pirelli Cinturato P7 All Season Plus, Pennzoil Platinum 5w20 & Fram Pro Synthetic Filter, Valvoline MERCON V, Valvoline DOT 3&4, ZEREX G-05, Top Tier Regular Gas
rjacket is offline  
post #26 of 28 (permalink) Old 10-17-2016, 10:09 AM
Junior Member
 
Join Date: Oct 2016
Location: la
Chapter: Southern
Year: 2000
Model: Ford Taurus
Engine: 3.0L 12v Vulcan V6
Posts: 5
Rep Power: 0
 
Trader Score: 0 reviews
I used a ps filter from autozone after my ps pump started to make a noise and it works good.
rwik is offline  
post #27 of 28 (permalink) Old 02-07-2018, 12:41 AM
Junior Member
 
Join Date: Feb 2017
Location: Alberta
Chapter: West Coast
Year: 1989
Model: Ford Taurus
Engine: 3.0L 12v Vulcan V6
Posts: 3
Rep Power: 0
 
Trader Score: 0 reviews
Quote:
Originally Posted by thecraze View Post
What is this cylinder? Is this a power steering filter, too?
Did you figure it out?

Quote:
Originally Posted by pawpaw View Post
Look on page 2, post 18 of this thread, for the factory power steering filter location & what it & the Magnefine filters look like.
Post 18 does not include the answer. That black cylinder shape thing is at the high presure line, not the return line.
renguomin is offline  
post #28 of 28 (permalink) Old 01-24-2019, 11:36 PM Thread Starter
Devoted Member
 
Join Date: Apr 2003
Location: Virginia
Chapter: Southeast
Year: 94
Model: Ford Taurus
Engine: 3.8L Essex
Posts: 2,433
Rep Power: 44
 
Trader Score: 0 reviews
BUMP: !0th year Update!!!

!0 years & 5 months ago I cleaned/flushed the 94 Taurus & 99 Ranger power steering systems with Sea Foam Trans Tune, the specified licensed fluids & added a Magnefine inline fluid filter to the low pressure/return lines after the fluid cooler, to see if it would make any positive difference in the intermittent returning loss of boost & or off center shudder both systems developed, even though both were getting a Full system fluid flush every 30K miles when the tranny in both vehicles got their pan drop, filter change & full fluid pump outs & in spite of the fluid maintenance Both power steering systems developed the same problems.

As reported over the years, after the Trans Tune flush, filling with the specified fluids licensed to meet Fords specifications & adding the Magnefine inline filter back in 08, both systems have remained trouble free for 10 years & 5 months now. Both pumps remain quiet. The Taurus pump Really got quiet after its service in 08 & remains so. The Ranger pump never has been noisy like the Taurus pump got, but as mentioned it too developed the intermittent loss of boost & off center shudder but hasn't returned after adding the inline Magnefine filter.

Magnefine has moved their manufacturing to the USA & now has a Metal body filter housing, so I'm about to change both filters to the new design, as both are 10 years old & close to 30K miles on them, so time for a change.

As mentioned a couple of years ago I'll open both filters & inspect the media & magnet for debris to see if anything obvious turns up & will post some pictures on this thread as a update for the record.

Right now I have no idea why adding the filter seems to have fixed the problem, as both systems fluids looked & smelled fine & easily passed the poor mans blotter spot tests at 30K flush intervals. So we shall see if the filter media, or magnet reveal any suspects they've captured.

94 Taurus GL 3.8L PEP204A
99 Ranger XLT 4dr 4.0L 5spd Auto
Payload & Tow Pkg

Details are trifles, but trifles make perfection & perfection is no trifle (Ben Franklin)
Our signature is a sign of a job completed, autograph your work with excellence.
pawpaw is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome