TollKeepers 2005 Mercury Montego - Page 3 - Taurus Car Club of America : Ford Taurus Forum
 12Likes
Reply
 
LinkBack Thread Tools
post #21 of 32 (permalink) Old 05-23-2019, 05:23 PM
Gen 5/6 Forum Moderator
 
Join Date: Nov 2013
Location: Buffalo, NY
Chapter: Northeast
Year: 2017
Model: OTHER
Engine: OTHER
Posts: 3,010
Rep Power: 29
  
Trader Score: 0 reviews
Awesome. Maiden voyage here you come!

For kicks I tried to find a Five Hundred AWD CVT--couldn't find a single one that wasn't rusted out. Keep us posted.

thefranchise713

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Follow my new story with the Bull's taller, older sister:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Our lives are a series of missions, aided by our gifts and talents, in pursuit of a stronger neighborhood.
thefranchise713 is offline  
Sponsored Links
Advertisement
 
post #22 of 32 (permalink) Old 05-23-2019, 09:49 PM Thread Starter
Senior Member
 
TollKeeper's Avatar
 
Join Date: Aug 2018
Location: Denver, Colorado
Chapter: Pacific Northwest
Year: 2005
Model: Mercury Montego
Engine: 3.0L 24v Duratec V6
Posts: 649
Rep Power: 3
 
Garage
Trader Score: 0 reviews
Body Work done... now to the interior...




But it almost didnt happen... Went to pick it up at the shop, and my dash was a christmas tree, no speedo, no tach, no fuel, no temp, all these different warnings running across the screen... I was starting to have a panic attack. So we started looking at fuses, and the battery, and everything we could think of.

At some point the mechanic kicked the carpet on the passenger floor board, and the gauges started working, but only for a second. I said "do that again", and he kicked the carpet, and it had the same outcome. So I shut off the engine, pulled back the carpet, and there is some BIG body control harness or something right there. He thinks his helper guy plugged it in, but didnt fold over the locking pull ring thingy (no idea what its called). Started the engine, and all was back to normal.

This thingy

Brian - Carpe Diem

2005 Mercury Montego 52k
2004 GMC Envoy XUV 182k
2001 Pontiac Aztek GT AWD 120K
TollKeeper is offline  
post #23 of 32 (permalink) Old 05-23-2019, 10:34 PM Thread Starter
Senior Member
 
TollKeeper's Avatar
 
Join Date: Aug 2018
Location: Denver, Colorado
Chapter: Pacific Northwest
Year: 2005
Model: Mercury Montego
Engine: 3.0L 24v Duratec V6
Posts: 649
Rep Power: 3
 
Garage
Trader Score: 0 reviews
Quote:
Originally Posted by thefranchise713 View Post
Awesome. Maiden voyage here you come!

For kicks I tried to find a Five Hundred AWD CVT--couldn't find a single one that wasn't rusted out. Keep us posted.
She has already had a few "maiden" voyages. I try to drive it as much as I can without Johnny Law getting involved. Need to keep the flat spots off the tires, oil flowing, tranny fluid moving, etc.

I drove it home tonight from the Body Shop, its going to be so nice to get the fuel mileage that the dash is showing me. I love my GMC, but at 15 MPG.... The dash was showing me 29.4 MPG. Even if it falls to 25, I would be happy!

New York is BAD about getting anything rust free. I remember delivering car parts up there, and seeing 2-3 year old cars showing signs of rust. I dont buy anything north of Kentucky, or East of Kansas City just for that reason. The rust problem is even worse over in Detroit/Michigan.

Brian - Carpe Diem

2005 Mercury Montego 52k
2004 GMC Envoy XUV 182k
2001 Pontiac Aztek GT AWD 120K
TollKeeper is offline  
 
post #24 of 32 (permalink) Old 05-25-2019, 08:47 AM
Gen 5/6 Forum Moderator
 
Join Date: Nov 2013
Location: Buffalo, NY
Chapter: Northeast
Year: 2017
Model: OTHER
Engine: OTHER
Posts: 3,010
Rep Power: 29
  
Trader Score: 0 reviews
Oh, this was even using AutoTrader. Nationwide search. Incredible how much junk there was even in the rust-free states.

thefranchise713

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Follow my new story with the Bull's taller, older sister:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Our lives are a series of missions, aided by our gifts and talents, in pursuit of a stronger neighborhood.
thefranchise713 is offline  
post #25 of 32 (permalink) Old 05-25-2019, 01:27 PM Thread Starter
Senior Member
 
TollKeeper's Avatar
 
Join Date: Aug 2018
Location: Denver, Colorado
Chapter: Pacific Northwest
Year: 2005
Model: Mercury Montego
Engine: 3.0L 24v Duratec V6
Posts: 649
Rep Power: 3
 
Garage
Trader Score: 0 reviews
So spent the evening putting the interior back together on the car, everything went in perfectly. SRS airbag light turned off when I plugged in the seatbelts. So far so good. No lights on the dash. Interior lights turn off and on with the opening and closing of the door.

I just have to go to the yard for one trim bolt that I had when I started putting it together, but disappeared at some point. And I need 4 plastic clips for the rocker panel.

I will post some pics later tonight.
Jeff K likes this.

Last edited by TollKeeper; 05-25-2019 at 08:54 PM.
TollKeeper is offline  
post #26 of 32 (permalink) Old 05-25-2019, 08:42 PM Thread Starter
Senior Member
 
TollKeeper's Avatar
 
Join Date: Aug 2018
Location: Denver, Colorado
Chapter: Pacific Northwest
Year: 2005
Model: Mercury Montego
Engine: 3.0L 24v Duratec V6
Posts: 649
Rep Power: 3
 
Garage
Trader Score: 0 reviews
Did a complete wipe down of the interior, and took apart the drivers side knee bolster to find the door code. Found it, and the code works! Now to reprogram it to be an easier code that I use for everything. Trying to upload some pics now. It still needs a bath.

Last edited by TollKeeper; 05-25-2019 at 08:57 PM.
TollKeeper is offline  
post #27 of 32 (permalink) Old 05-25-2019, 08:52 PM Thread Starter
Senior Member
 
TollKeeper's Avatar
 
Join Date: Aug 2018
Location: Denver, Colorado
Chapter: Pacific Northwest
Year: 2005
Model: Mercury Montego
Engine: 3.0L 24v Duratec V6
Posts: 649
Rep Power: 3
 
Garage
Trader Score: 0 reviews
Finally got the pics to upload..





sheila likes this.
TollKeeper is offline  
post #28 of 32 (permalink) Old 05-25-2019, 10:28 PM Thread Starter
Senior Member
 
TollKeeper's Avatar
 
Join Date: Aug 2018
Location: Denver, Colorado
Chapter: Pacific Northwest
Year: 2005
Model: Mercury Montego
Engine: 3.0L 24v Duratec V6
Posts: 649
Rep Power: 3
 
Garage
Trader Score: 0 reviews
Quote:
Originally Posted by thefranchise713 View Post
Oh, this was even using AutoTrader. Nationwide search. Incredible how much junk there was even in the rust-free states.
They are out there. There are a couple examples of low mileage ones local to me too.
This one is way over priced, but it also only has 48k miles
https://denver.craigslist.org/ctd/d/...893185623.html

This one is more reasonably priced with 58k miles.
https://denver.craigslist.org/cto/d/...891080342.html

This one has 93k miles.
https://cosprings.craigslist.org/ctd...897325911.html

This one has 102k miles, and no photos....
https://denver.craigslist.org/ctd/d/...894828308.html

There are more, but they have higher miles.
https://denver.craigslist.org/ctd/d/...896751929.html

https://westslope.craigslist.org/cto...880275138.html

I wish I had found this Montego before I bought mine... This is a SUPER EASY fix.. I bet it sells for around 1500, with 62k miles, thats a steal!
https://www.copart.com/lot/33063769
kekaye56 likes this.

Brian - Carpe Diem

2005 Mercury Montego 52k
2004 GMC Envoy XUV 182k
2001 Pontiac Aztek GT AWD 120K

Last edited by TollKeeper; 05-25-2019 at 11:05 PM.
TollKeeper is offline  
post #29 of 32 (permalink) Old 05-26-2019, 09:52 AM
Crazy Devoted Member
 
Join Date: Jan 2010
Location: North Canton, Ohio
Chapter: Midwest
Year: 2006
Model: Ford Taurus
Engine: 3.0L 12v Vulcan V6
Posts: 6,446
Rep Power: 64
    
Trader Score: 0 reviews
What do you think you have invested in this project?
Automender12345 is offline  
post #30 of 32 (permalink) Old 05-26-2019, 10:10 AM Thread Starter
Senior Member
 
TollKeeper's Avatar
 
Join Date: Aug 2018
Location: Denver, Colorado
Chapter: Pacific Northwest
Year: 2005
Model: Mercury Montego
Engine: 3.0L 24v Duratec V6
Posts: 649
Rep Power: 3
 
Garage
Trader Score: 0 reviews
Quote:
Originally Posted by Automender12345 View Post
What do you think you have invested in this project?
Well 2 things happened that blew the budget. The auction house I bought the car from kinda screwed me, to the tune of 650 bucks (don't buy from Dashub). And then my back going out, and having to get a body shop more involved than planned, that was 1000 over budget.

My budget was 3200, all in complete, painted and plated. I'm at 4400 right now, but only have about 50 bucks to go (no paint).
TollKeeper is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 Montego, clunking driving me insane!! BullWaggin' 5th and 6th Gen Maintenance and Repair 8 01-25-2018 10:09 PM
Paul's 2005 Mercury Sable LS TaurusDailyDriver Taurus and Sable Project Log 37 05-29-2017 02:11 PM
Ttppss24s 2005 Mercury Montego Premier 2WD, (Tego) Ttppss24 Taurus and Sable Project Log 20 03-30-2016 07:43 PM
Air Conditioning Question - 2005 Mercury Sable fordguy1997 Maintenance and Repair 15 08-14-2015 10:50 PM
07 Mercury Montego electrical brake issue las59 Other Rides 3 05-03-2014 09:55 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome