Not sure with catalytic converter is bank 2 for 2007 Ford Taurus. - Page 2 - Taurus Car Club of America : Ford Taurus Forum
 2Likes
Reply
 
LinkBack Thread Tools
post #11 of 15 (permalink) Old 05-21-2019, 09:22 AM
Technical Advisor
 
Join Date: Feb 2007
Location: Milwaukee, WI
Chapter: Midwest
Year: 2005
Model: Ford Taurus
Engine: 3.0L 24v Duratec V6
Posts: 7,639
Rep Power: 87
     
Trader Score: 0 reviews
Cat outlet temp should be higher than inlet temp by 100 C at least. That, along with the 430 code, means cat is dead. Either replace the cat or, if the cat isnt clogged and reducing performance and MPG, spend $20 on "MIL eliminators", which look like the old spark plug antifoulers. Simply remove post cat O2, screw in the adapter, and screw the O2 into the adapter. They work.

05 Taurus SEL Duratec - my daily driver
04 Taurus SES Duratec - wifes car - TOTALED
06 Taurus SE Vulcan - wifes new ride
95 Taurus GL Vulcan winter car
Toy #1 - 86 Tbird 5.0 (original owner) - LOTS of mods
Toy #2 - 88 Tbird Turbo Coupe - LOTS of mods
67 Honda 450 Super Sport - completely customized
Jeff K is offline  
Sponsored Links
Advertisement
 
post #12 of 15 (permalink) Old 05-21-2019, 12:38 PM
Member
 
Join Date: Mar 2013
Location: WV
Chapter: Northeast
Posts: 173
Rep Power: 14
 
Trader Score: 0 reviews
Thanks. Think I will replace them if need be. I put it in the garage just to be sure. So we'll see.
blondechic451 is offline  
post #13 of 15 (permalink) Old 05-29-2019, 12:34 PM
Member
 
Join Date: Sep 2014
Location: Detroit metro
Chapter: Midwest
Year: 02
Model: Ford Taurus
Engine: 3.0L 12v Vulcan V6
Posts: 190
Rep Power: 10
 
Garage
Trader Score: 0 reviews
IF.. your mechanic is competent and thorough, he would have removed the upstream sensor and attached a pressure gauge. If pressure is >3psi convertor is restricting, and should be replaced. I wouldn't return your cat; as you will need it sooner or later.
rsteve56 is offline  
 
post #14 of 15 (permalink) Old 05-30-2019, 08:33 PM
Member
 
Join Date: Mar 2013
Location: WV
Chapter: Northeast
Posts: 173
Rep Power: 14
 
Trader Score: 0 reviews
You aren't kidding! That PO430 code came back on today.
blondechic451 is offline  
post #15 of 15 (permalink) Old 07-10-2019, 09:09 AM
Member
 
Join Date: Mar 2013
Location: WV
Chapter: Northeast
Posts: 173
Rep Power: 14
 
Trader Score: 0 reviews
I changed both 02 sensors and my car did great the start with (had the code erased) but CEL finally came back on yesterday and my car is constantly revving up and down while stopping at a light or in park. Pulling 2 codes for the cat. Auto store said it was my 02 sensors. Will they act up like this because the cat is clogged?
blondechic451 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Used Taurus/Sable Finds - Post them here! bull geek Taurus and Sable General Discussion 989 07-19-2019 06:16 PM
P0430 2007 Ford Taurus NEED HELP ASAP Mvp Swagz Maintenance and Repair 7 03-30-2018 09:58 AM
Official Northeast Chapter Member Information TaurusDailyDriver Northeast Chapter Forum 1 06-27-2014 11:01 PM
Ford will not acknowledge their own recall! (1986-95 Taurus, Sable, Continental) Brian_05_SEL Taurus and Sable General Discussion 11 09-14-2013 10:15 PM
Recall 96s51 joshuapace Maintenance and Repair 2 01-16-2006 01:25 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome