Brakes rubbing rim 96 3.0 SE??? - Taurus Car Club of America : Ford Taurus Forum
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 03-13-2012, 02:02 PM Thread Starter
Junior Member
 
Join Date: Mar 2012
Location: Milwaukee
Chapter: Midwest
Posts: 1
Rep Power: 0
 
Trader Score: 0 reviews
Brakes rubbing rim 96 3.0 SE???

Hi. First timer here. After finally getting my 1996 SE 3.0 started (it had sat for a year - unrelated problem), I had shifted into reverse to back out the driveway when there was a loud grinding noise. I called my wife out to look while I did it again & she said it was coming from the drivers side front wheel. We switched places and it appears that there is part of the brakes (pads??) actually rubbing against the inside of the rim (stock aluminum). Is this possible? This was NOT happening when the car had first "died". Brakes redone at 44k, car has 72k (yes, low mileage - only used to go to work and back). Thanks so much in advance for any help/thoughts.
tomdusick is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-13-2012, 02:32 PM
Junior Member
 
Join Date: Jul 2011
Location: Ft Stewart, Georgia
Posts: 86
Rep Power: 17
 
Trader Score: 0 reviews
rust on the rotors I bet....
calvin0325 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome