No Display 2013 Taurus - Taurus Car Club of America : Ford Taurus Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 06-16-2019, 04:33 PM Thread Starter
Junior Member
 
Join Date: Jun 2019
Location: Edmundston, New Brunswick, Canada
Chapter: Eastern Canada
Year: 2013
Model: Ford Taurus Police Interceptor
Engine: 3.5L Ti-VCT V6
Posts: 3
Rep Power: 0
 
Trader Score: 0 reviews
No Display 2013 Taurus

When I turn my car on the only thing that comes up on my Radio Display is Date, Time, Ext temp.
And everything else is blank.
I have a 2013 Taurus Police Interceptor and I wonder if the INSTALLER has removed anything from radio/amp before it was sold.

There are 3 wires total in the back 1 is ground clipped on , 1 is a small plug into the back of the radio/control panel, the other wire is in the back of the AMP which is a multi wire plug.

I do see a small socket for another wire to plug into on the radio but unsure what it is for.
Any Ideas?

Ray
Razor60 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Taurus Car Club of America : Ford Taurus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
2013 Taurus RosalindaG93 Introduction Forum 3 02-19-2018 08:40 PM
2011 Taurus SEL Display quit parleee 5th and 6th Gen Electronics, Security, Audio and Visual 13 02-24-2017 10:09 AM
2013 Taurus limited Alternator Removal quadcells 5th and 6th Gen Maintenance and Repair 14 09-16-2016 09:23 AM
Some mods on a 2013 Taurus SEL? James417 5th and 6th Gen Engine and Drivetrain 15 03-24-2016 12:23 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome